bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

B2G Wifi: WPS automatic Wifi network configuration is not working

RESOLVED WORKSFORME

Status

()

Core
DOM: Device Interfaces
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: carlosmartinez, Assigned: chucklee)

Tracking

18 Branch
ARM
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Tested in an unagi device with Gecko-f946f29.Gaia-ae169d8.

STR:
1-Open settings app
2-Go to Wifi
3-Open Connect with WPS
4-Tap in the Button connection option
5-Press OK

Expected result --> After some time you´re connected to the network prepared for a WPS connection

Actual result --> Network connection always times out

Logcat error:

W/wpa_supplicant(  504): wlan0: Failed to initiate AP scan

So, seems like is not able to search for wifi networks with WPS ready, but is able to search for Wifi networks and connect to them without WPS.
"Failed to initiate AP scan" is an already-known message, but that doesn't affect the wifi functionality.

WPS Push Button works fine with my test AP(ASUS RT-N16), did you activate WPS Push Button on AP while connecting?

If so, please attach full logcat so I can check the detail, thanks.
Assignee: nobody → chulee
I can't reproduce the problem and no further information is provided, mark as WFM.
Please reopen if described issue happens again with debug information.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.