Inconsistent close behaviour of private windows

RESOLVED FIXED in seamonkey2.19

Status

SeaMonkey
General
--
minor
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: neil@parkwaycc.co.uk, Assigned: neil@parkwaycc.co.uk)

Tracking

(Blocks: 1 bug)

Trunk
seamonkey2.19
Dependency tree / graph

SeaMonkey Tracking Flags

(seamonkey2.18 fixed, seamonkey2.19 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
Private Windows close without prompting if there are no normal browser windows open, but if there is a browser window open, then the private window prompts as if it was a browser window.

According to bug 844561, Private Windows should never prompt.
(Assignee)

Comment 1

4 years ago
Created attachment 720123 [details] [diff] [review]
Proposed patch

I'm assuming that we still need to honour unbeforeunload.
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #720123 - Flags: review?(philip.chee)
Attachment #720123 - Flags: review?(iann_bugzilla)
(Assignee)

Comment 2

4 years ago
I mean onbeforeunload. I typed it right the first two times when Bugzilla errored out on me :-(

Comment 3

4 years ago
(In reply to neil@parkwaycc.co.uk from comment #2)
> I mean onbeforeunload. I typed it right the first two times when Bugzilla
> errored out on me :-(

I cannot see where we listener for "beforeunload" in the suite.

Updated

4 years ago
Attachment #720123 - Flags: review?(iann_bugzilla) → review+
(Assignee)

Comment 4

4 years ago
(In reply to Ian Neal from comment #3)
> (In reply to comment #2)
> > I mean onbeforeunload. I typed it right the first two times when Bugzilla
> > errored out on me :-(
> 
> I cannot see where we listener for "beforeunload" in the suite.

We don't listen for it, pages do. We send it by means of the permitUnload call near the end of WindowIsClosing().
(Assignee)

Comment 5

4 years ago
Pushed comm-central changeset 70b7a4895fb3.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

4 years ago
Comment on attachment 720123 [details] [diff] [review]
Proposed patch

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: Unexpected prompt to close private windows
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): Low
String changes made by this patch: None
Attachment #720123 - Flags: approval-comm-aurora?

Updated

4 years ago
Attachment #720123 - Flags: approval-comm-aurora? → approval-comm-aurora+

Comment 7

4 years ago
Comment on attachment 720123 [details] [diff] [review]
Proposed patch

ex post facto r=me :P

> +  if (!gPrivate && !/Mac/.test(navigator.platform) && isClosingLastBrowser()) {
Too late to mention this but could have changed this to:
!navigator.platform.contains("Mac");
Attachment #720123 - Flags: review?(philip.chee) → review+

Updated

4 years ago
Target Milestone: --- → seamonkey2.19
(Assignee)

Comment 8

4 years ago
Pushed comm-aurora changeset 709c8c3e914b.
status-seamonkey2.18: affected → fixed
status-seamonkey2.19: affected → fixed
You need to log in before you can comment on or make changes to this bug.