Closed Bug 846786 Opened 8 years ago Closed 8 years ago

java.lang.NullPointerException: at org.mozilla.gecko.gfx.GfxInfoThread.hasData(GfxInfoThread.java)

Categories

(Firefox for Android :: Toolbar, defect)

22 Branch
ARM
Android
defect
Not set
critical

Tracking

()

RESOLVED FIXED
Firefox 22
Tracking Status
firefox20 --- unaffected
firefox21 --- fixed
firefox22 --- fixed

People

(Reporter: scoobidiver, Assigned: kats)

References

Details

(Keywords: crash, regression, topcrash, Whiteboard: [native-crash][startupcrash])

Crash Data

Attachments

(1 file)

It has been hit by four users in 22.0a1/20130103, including bp-540e2414-5b13-429e-9812-6ea3a2130301. The regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b0e08db3bc2a&tochange=993d7aff3109
It's likely a regression from bug 844275.

java.lang.NullPointerException
	at org.mozilla.gecko.gfx.GfxInfoThread.hasData(GfxInfoThread.java:38)
	at org.mozilla.gecko.gfx.GLController$1.run(GLController.java:129)
	at android.os.Handler.handleCallback(Handler.java:605)
	at android.os.Handler.dispatchMessage(Handler.java:92)
	at android.os.Looper.loop(Looper.java:137)
	at android.app.ActivityThread.main(ActivityThread.java:4507)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:511)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:978)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:745)
	at dalvik.system.NativeStart.main(Native Method)

More reports at:
https://crash-stats.mozilla.com/report/list?signature=java.lang.NullPointerException%3A+at+org.mozilla.gecko.gfx.GfxInfoThread.hasData%28GfxInfoThread.java%29
Yeah, my mistake. I didn't realize there things other than compositor creation that can call GfxInfo::EnsureInitializedFromGfxInfoData, so it is possible for GfxInfoThread.sInstance to be null when GLController.mCompositorCreated is false. Should be an easy fix.
Assignee: nobody → bugmail.mozilla
Attached patch PatchSplinter Review
I'm still building this but I'm pretty confident in it. Note that another option is to make GfxInfoThread.getData() not null out sInstance, but then we'll leak the GfxInfoThread instance unnecessarily, so I prefer this approach.
Attachment #720042 - Flags: review?(chrislord.net)
It's #5 top crasher over the last week.
Keywords: topcrash
Comment on attachment 720042 [details] [diff] [review]
Patch

Review of attachment 720042 [details] [diff] [review]:
-----------------------------------------------------------------

Looks ok, but at this point I think you're a much better judge of this than I am...
Attachment #720042 - Flags: review?(chrislord.net) → review+
https://hg.mozilla.org/mozilla-central/rev/69043531c962
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 22
Comment on attachment 720042 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 844275
User impact if declined: needs to land as a follow-up to bug 844275
Testing completed (on m-c, etc.): on m-c, aurora try build at https://tbpl.mozilla.org/?tree=Try&rev=26b79db37644
Risk to taking this patch (and alternatives if risky): low risk, fennec only
String or UUID changes made by this patch: none
Attachment #720042 - Flags: approval-mozilla-aurora?
Comment on attachment 720042 [details] [diff] [review]
Patch

bug 844275 is recently approved on aurora.Need to approve this to avoid introducing the top-crasher in Fx21
Attachment #720042 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.