Tab Group confused for popup, users delete data unknowingly

RESOLVED WONTFIX

Status

Firefox Graveyard
Panorama
RESOLVED WONTFIX
5 years ago
2 years ago

People

(Reporter: JLinks22, Unassigned)

Tracking

19 Branch
x86
Windows 7

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:16.0) Gecko/20121026 Firefox/16.0
Build ID: 20121026125834

Steps to reproduce:

A user not usually at my work machine accidentally pressed the tab candy button, and was then entirely confused. She thought the tab group was a popup and pressed the 'x'.


Actual results:

The undo option was of no use, as she did not yet know she had deleted anything. I'm a professional web developer and a 'power user' in the sense that I commonly have over 50 tabs open at a time, including various articles, message board conversations, and reference pages for projects I am working on. All of these were gone in an instant, with no way to recover more than the last 8 under 'recently closed tabs', somewhat decimating my work flow.


Expected results:

Firefox should take much greater care in protecting the user's session data. History could remember when each tab was opened and closed, making it easy to go back to any recent point. It should never be easy to accidentally delete data. Additionally, I have never found it easy to back up this information myself, suggesting a feature to do so should be provided.
(Reporter)

Updated

5 years ago
See Also: → bug 630792
(Reporter)

Updated

5 years ago
Component: Untriaged → Panorama

Comment 1

5 years ago
Panorama is going to be removed in the future, so it will fix automatically your issue (see bug 836758).
Panorama has been removed from Firefox 45, currently in Beta and scheduled for release on March 7th. As such, I'm closing all existing Panorama bugs.

If you are still using Panorama, you will see a deprecation message in Firefox 44, and when 45 is released your tab group data will be migrated to bookmarks, with a folder for each group. There are also a few addons offering similar functionality.

See https://support.mozilla.org/en-US/kb/tab-groups-removal for more info.

We're removing Panorama because it has extremely low usage (about 0.01% of users), and has a large number of bugs and usability issues. The cost of fixing all those issues is far too high to justify, and so we'll instead be focusing our time and energy on improving other parts of Firefox.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

2 years ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.