Form reload retains values

VERIFIED DUPLICATE of bug 21767

Status

()

Toolkit
Form Manager
--
minor
VERIFIED DUPLICATE of bug 21767
17 years ago
10 years ago

People

(Reporter: Joel Grimes, Assigned: Stephen P. Morse)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.1) Gecko/20010607
BuildID:    20010600703

When a form is reloaded, the values aren't removed

Reproducible: Always
Steps to Reproduce:
1. load this form:



<html>
<head>
	<title>Untitled</title>
</head>

<body>
<form action="http://www.mozilla.org">

<select name="firstselect" multiple size="4">
	<option value="1">lakers
	<option value="2">lakers
	<option value="3">lakers
	<option value="4">lakers
</select>
<br>
<br>
<select name="secondselect" multiple size="4">
	<option value="1">sixers
	<option value="2">sixers
	<option value="3">sixers
	<option value="4">sixers
</select>

<input type="submit">
</form>


</body>
</html>

2.select a value in either 1 or both selects
3.Refresh the form.  Your selections are still there
4.Double click on the url and hit enter, your selections are gone
5.Refresh the form, your selections have returned

Actual Results:  Selected items are retained

Expected Results:  On step 5, selected items should not be retained

Same on other types of form elements
(Reporter)

Comment 1

17 years ago
Shouldn't form elements clear on ANY reload?

Comment 2

17 years ago
See also bug 82477 (and the list of related ones in the comments.)
Currently, shift reload will clear the form.

Comment 3

17 years ago
It's a dupe of bug 82477, which, in turn, is marked as dupe of bug 21767.
Marking dupe...

*** This bug has been marked as a duplicate of 21767 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 4

17 years ago
Verified Duplicate
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: Form Manager → Form Manager
Product: Core → Toolkit
QA Contact: tpreston → form.manager
You need to log in before you can comment on or make changes to this bug.