Closed Bug 846876 Opened 8 years ago Closed 8 years ago

Profiler: Message to warn about already running, different profile shows (null) instead of profile number

Categories

(DevTools :: Performance Tools (Profiler/Timeline), defect, P1)

x86
Windows XP
defect

Tracking

(firefox21 verified, firefox22 unaffected)

RESOLVED FIXED
Firefox 21
Tracking Status
firefox21 --- verified
firefox22 --- unaffected

People

(Reporter: aryx, Assigned: anton)

Details

Attachments

(1 file)

Firefox nightly 20130301 and Aurora from earlier this week, Windows XP SP3 32 bit

The message to warn the user about an already running, different profile shows '(null)' instead of the profile number.

Steps to reproduce:
1. Launch profiler.
2. Start profiling in Profile 1.
3. Hit the 'New' button to create a second profile.

Actual result:
Warning about 'Profile (null)' running.

Expected result:
Profile number shown.
Assignee: nobody → anton
Priority: -- → P1
Target Milestone: --- → Firefox 21
This bug doesn't affect Nightlies anymore because there we allow multiple profiles to run in the same time. Only Aurora for now.
Attachment #730980 - Flags: review?(past)
Attachment #730980 - Flags: review?(dcamp)
Status: NEW → ASSIGNED
Attachment #730980 - Flags: review?(dcamp) → review+
Comment on attachment 730980 [details] [diff] [review]
Use this.panel._runningUid instead of this._runningUid

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 830664
User impact if declined: Users running multiple profiles will see (null) instead of a profile number in one of the UI hints.
Testing completed (on m-c, etc.): Local. Some basic smoke-testing and unit tests.
Risk to taking this patch (and alternatives if risky): None as I can see. The patch fixes code that doesn't work otherwise.
String or IDL/UUID changes made by this patch: None.
Attachment #730980 - Flags: approval-mozilla-aurora?
Attachment #730980 - Flags: review?(past)
Comment on attachment 730980 [details] [diff] [review]
Use this.panel._runningUid instead of this._runningUid

low risk patch , approving for uplift
Attachment #730980 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/66301943ef84
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:21.0) Gecko/20100101 Firefox/21.0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0
Mozilla/5.0 (X11; Linux i686; rv:21.0) Gecko/20100101 Firefox/21.0
BuildID: 20130401192816 

Verified on latest Firefox 21 build 1: The number of the profile on which the Profiler is running is displayed in the profiler is already running message.
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.