Playing mp3 audio file on Firefox 19 gives error "Video can't be played because the file is corrupt," causes Firefox Beta 20, Aurora, and Nightly builds to immediately crash.

RESOLVED DUPLICATE of bug 846465

Status

()

Firefox for Android
General
RESOLVED DUPLICATE of bug 846465
5 years ago
a year ago

People

(Reporter: Todd, Unassigned)

Tracking

19 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 720081 [details]
Screenshot_2013-02-28-23-12-25.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130215130331

Steps to reproduce:

Tap and select a direct link to an mp3 file.


Actual results:

Firefox 19 gives error message "Video can't be played because the file is corrupt." Firefox Beta 20, Aurora, and Nightly builds immediately crash without an error message.


Expected results:

Playback of audio file.
(Reporter)

Updated

5 years ago
OS: Windows 7 → Android
Hardware: x86_64 → ARM
(Reporter)

Comment 1

5 years ago
Device is AT&T HTC One X+ running stock Android rom 4.1.1
Sounds like a dupe of bug 846465. Did you submit a crash report? Can you go to about:crashes and let us know what the crash report ID is?
(Reporter)

Comment 3

5 years ago
ID: 21e263fd-8a9c-4ef0-907c-e0ae42130301

Report is from Firefox 20 Beta. The only non-default add-on installed is Adblock Plus, although crashes occurred even before installation. Bug 846465 does appear under "Related Bugs" in the crash report.
Thanks for filing. 

If you have exact steps to reproduce, like the file you clicked on and how to reproduce the crash can you please add them in bug 846465?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 846465
You need to log in before you can comment on or make changes to this bug.