[B2G][Calendar] Creating an event while on a previous date results in defaulting to the current date

VERIFIED DUPLICATE of bug 846940

Status

VERIFIED DUPLICATE of bug 846940
6 years ago
5 years ago

People

(Reporter: mlevin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: testrun 5.1)

(Reporter)

Description

6 years ago
Description:
When on a previous date in the calendar, the User tries to create an event using the "+" symbol, results in the current date defaulting in the date fields.

Repro Steps:
1) Update Unagi to build ID: 20130225070200
2) Open Calendar.
3) Swipe to the previous month from the current month.
4) Tap one of the days in the previous month.
5) Tap the "+" in the top upper right part of the Unagi screen in order to add a new event in the past.

Expected:
Event screen to open showing the previous month's date the User chose in the date fields.

Actual:
Date fields in the Event screen show "today's" date instead of the date in the past that the User chose.

Repro frequency:
4/4

Environmental  Variables:
Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/3a5a27992a75
Gaia: 5691a16fff8e1403c75ed9d6f3a443b7e58198c6

Notes:
Test Suite Name: Calendar
UCID: calendar-026
Test Case ID#: 6168
Link to the test case: https://moztrap.mozilla.org/runtests/run/859/env/305/?pagenumber=1&pagesize=20&sortfield=order&sortdirection=asc&filter-id=6168

This is NOT a typical use case.
Workaround: When the Event screen opens click on the date field, and force the change in the past by changing the date.

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 846940

Comment 2

5 years ago
Verified issue as a dupe of bug 846949
Status: RESOLVED → VERIFIED

Comment 3

5 years ago
correction for comment 2
Verified issue as a dupe of bug 846940
You need to log in before you can comment on or make changes to this bug.