Closed Bug 847011 Opened 7 years ago Closed 7 years ago

cannot create regular file `res/drawable-mdpi/icon.png': No such file or directory

Categories

(Firefox Build System :: General, defect)

ARM
Android
defect
Not set

Tracking

(firefox21 fixed, firefox22 fixed)

RESOLVED FIXED
mozilla22
Tracking Status
firefox21 --- fixed
firefox22 --- fixed

People

(Reporter: glandium, Assigned: glandium)

References

Details

Attachments

(1 file)

/builds/slave/m-aurora-and-l10n_5-0000000000/build/mozilla-aurora/obj-l10n/_virtualenv/bin/python /builds/slave/m-aurora-and-l10n_5-0000000000/build/mozilla-aurora/config/Preprocessor.py \
06:18:48     INFO -                -DOBJDIR="`pwd`" -DMANGLED_ANDROID_PACKAGE_NAME=org.mozilla.f3nn3c_aurora -DANDROID_PACKAGE_NAME=org.mozilla.fennec_aurora -DANDROID_CPU_ARCH=armeabi-v7a -DMOZ_APP_DISPLAYNAME="Aurora" -DMOZ_APP_NAME=fennec -DMOZ_APP_VERSION=21.0a2 -DMOZ_APP_ID={aa3c5121-dab2-40e2-81ca-7ea25febc110} -DMOZ_CHILD_PROCESS_NAME=lib/libplugin-container.so -DMOZ_MIN_CPU_VERSION=7 -DMOZ_CRASHREPORTER=1 -DMOZ_UPDATE_CHANNEL=aurora -DANDROID_VERSION_CODE=2013030104 -DMOZILLA_OFFICIAL=1 -DUA_BUILDID=20130301 -DMOZ_APP_BASENAME=Fennec -DMOZ_APP_BUILDID=20130301042013 -DMOZ_APP_ABI=arm-eabi-gcc3 -DMOZ_BUILD_TIMESTAMP=1362147528 -DMOZ_UPDATER=1 -DOS_TARGET=Android  -DMOZ_ANDROID_SHARED_ID=""org.mozilla.fennec.sharedID"" -DMOZ_ANDROID_SHARED_ACCOUNT_TYPE=""org.mozilla.fennec_sync"" -DNO_NSPR_10_SUPPORT -DANDROID=1 -DANDROID_VERSION=5 -DCROSS_COMPILE=1 -DX_DISPLAY_MISSING=1 -DMOZ_THUMB2=1 -DHAVE_ARM_SIMD=1 -DHAVE_ARM_NEON=1 -DJSGC_INCREMENTAL=1 -DMOZ_ENABLE_PROFILER_SPS=1 -DMOZILLA_VERSION=\"21.0a2\" -DMOZILLA_VERSION_U=21.0a2 -DMOZILLA_UAVERSION=\"21.0\" -DNO_PW_GECOS=1 -DMOZ_LINKER=1 -DD_INO=d_ino -DSTDC_HEADERS=1 -DHAVE_SSIZE_T=1 -DHAVE_ST_BLKSIZE=1 -DHAVE_SIGINFO_T=1 -DHAVE_UINT=1 -DHAVE_UINT_T=1 -DHAVE_UNAME_DOMAINNAME_FIELD=1 -DHAVE_VISIBILITY_HIDDEN_ATTRIBUTE=1 -DHAVE_VISIBILITY_ATTRIBUTE=1 -DHAVE_DIRENT_H=1 -DHAVE_GETOPT_H=1 -DHAVE_MEMORY_H=1 -DHAVE_UNISTD_H=1 -DHAVE_MALLOC_H=1 -DHAVE_SYS_SYSMACROS_H=1 -DHAVE_LINUX_QUOTA_H=1 -DHAVE_LINUX_RTNETLINK_H=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_NETINET_IN_H=1 -DHAVE_BYTESWAP_H=1 -DHAVE_SYS_CDEFS_H=1 -DHAVE_DLOPEN=1 -DHAVE_MEMMEM=1 -DNO_X11=1 -DHAVE_STRERROR=1 -DHAVE_LCHOWN=1 -DHAVE_FCHMOD=1 -DHAVE_SNPRINTF=1 -DHAVE_MEMMOVE=1 -DHAVE_SETBUF=1 -DHAVE_ISATTY=1 -DHAVE_FLOCKFILE=1 -DHAVE_LOCALTIME_R=1 -DHAVE_STRTOK_R=1 -DHAVE_CLOCK_MONOTONIC=1 -DMALLOC_H=\<malloc.h\> -DHAVE_STRNDUP=1 -DHAVE_MEMALIGN=1 -DHAVE_VALLOC=1 -DHAVE_I18N_LC_MESSAGES=1 -DNS_ATTR_MALLOC=__attribute__\(\(malloc\)\) -DNS_WARN_UNUSED_RESULT=__attribute__\(\(warn_unused_result\)\) -DMOZ_UPDATE_CHANNEL=aurora -DMOZ_BUILD_APP=mobile/android -DMOZ_WIDGET_ANDROID=1 -DMOZ_PDF_PRINTING=1 -DMOZ_INSTRUMENT_EVENT_LOOP=1 -DUSE_ARM_KUSER=1 -DMOZ_DISTRIBUTION_ID=\"org.mozilla\" -DMOZ_ANDROID_HISTORY=1 -DMOZ_ANDROID_OMTC=1 -DIBMBIDI=1 -DACCESSIBILITY=1 -DNS_PRINTING=1 -DNS_PRINT_PREVIEW=1 -DMOZ_SAMPLE_TYPE_S16=1 -DMOZ_RAW=1 -DMOZ_OGG=1 -DATTRIBUTE_ALIGNED_MAX=64 -DMOZ_WEBM=1 -DMOZ_DASH=1 -DMOZ_MEDIA_PLUGINS=1 -DMOZ_MEDIA_NAVIGATOR=1 -DMOZ_OMX_PLUGIN=1 -DMOZ_VP8=1 -DVPX_ARM_ASM=1 -DMOZ_WAVE=1 -DMOZ_SYDNEYAUDIO=1 -DMOZ_SPEEX_RESAMPLER=1 -DMOZ_SOUNDTOUCH=1 -DMOZ_MEDIA=1 -DMOZ_TREMOR=1 -DMOZ_OPUS=1 -DENABLE_SYSTEM_EXTENSION_DIRS=1 -DMOZ_CRASHREPORTER=1 -DMOZ_CRASHREPORTER_ENABLE_PERCENT=100 -DLIBJPEG_TURBO_ARM_ASM=1 -DMOZ_USE_NATIVE_POPUP_WINDOWS=1 -DMOZ_FLEXBOX=1 -DMOZ_TREE_FREETYPE=1 -DHAVE_FT_BITMAP_SIZE_Y_PPEM=1 -DHAVE_FT_GLYPHSLOT_EMBOLDEN=1 -DHAVE_FT_LOAD_SFNT_TABLE=1 -DMOZ_SIGNING=1 -DMOZ_UPDATER=1 -DMOZ_DISABLE_CRYPTOLEGACY=1 -DMOZ_FEEDS=1 -DMOZ_SAFE_BROWSING=1 -DMOZ_URL_CLASSIFIER=1 -DGL_PROVIDER_=1 -DMOZ_GFX_OPTIMIZE_MOBILE=1 -DMOZ_DEBUG_SYMBOLS=1 -DMOZ_LOGGING=1 -DSIZEOF_INT_P=4 -DMOZ_MEMORY_SIZEOF_PTR_2POW=2 -DMOZ_MEMORY=1 -DMOZ_MEMORY_LINUX=1 -DMOZ_MEMORY_ANDROID=1 -DJSGC_INCREMENTAL=1 -DJS_CRASH_DIAGNOSTICS=1 -DHAVE__UNWIND_BACKTRACE=1 -DJS_DEFAULT_JITREPORT_GRANULARITY=3 -DMOZ_OMNIJAR=1 -DMOZ_USER_DIR=\".mozilla\" -DMOZ_STATIC_JS=1 -DMOZ_TREE_PIXMAN=1 -DHAVE_STDINT_H=1 -DHAVE_INTTYPES_H=1 -DMOZ_TREE_CAIRO=1 -DHAVE_UINT64_T=1 -DMOZ_GRAPHITE=1 -DMOZ_ENABLE_SKIA=1 -DMOZ_XUL=1 -DMOZ_PROFILELOCKING=1 -DBUILD_CTYPES=1 -DMOZ_APP_COMPONENT_INCLUDE=\"nsBrowserComponents.h\" -DMOZ_MACBUNDLE_ID=org.mozilla.aurora -DMOZ_B2G_VERSION=\"1.0.0\" -DMOZ_B2G_OS_NAME=\"\" -DMOZ_APP_UA_NAME=\"Firefox\" -DMOZ_APP_UA_VERSION=\"21.0a2\" -DFIREFOX_VERSION=21.0a2 -DMOZ_UA_BUILDID=\"\" -DMOZ_TELEMETRY_DISPLAY_REV=2 -DMOZ_DATA_REPORTING=1 -DMOZ_DLL_SUFFIX=\".so\" -DXP_UNIX=1 /builds/slave/m-aurora-and-l10n_5-0000000000/build/mozilla-aurora/mobile/android/base/AndroidManifest.xml.in > AndroidManifest.xml
06:18:48     INFO -  /builds/slave/m-aurora-and-l10n_5-0000000000/build/mozilla-aurora/obj-l10n/config/nsinstall -D res/drawable
06:18:48     INFO -  cp /builds/slave/m-aurora-and-l10n_5-0000000000/build/mozilla-aurora/mobile/android/branding/aurora/content/fennec_48x48.png res/drawable-mdpi/icon.png
06:18:48     INFO -  cp: cannot create regular file `res/drawable-mdpi/icon.png': No such file or directory
06:18:48    ERROR -  make[2]: *** [res/drawable-mdpi/icon.png] Error 1


The problem comes from the following rule in mobile/android/base/Makefile.in:
res/drawable-mdpi/icon.png: $(MOZ_APP_ICON)
        $(NSINSTALL) -D res/drawable
        cp $(ICON_PATH) $@
Assignee: nobody → mh+mozilla
Depends on: 847014
Blocks: 846740
No longer depends on: 846740
Comment on attachment 720251 [details] [diff] [review]
Fix NSINSTALL in res/drawable-mdpi/icon.png rule

Review of attachment 720251 [details] [diff] [review]:
-----------------------------------------------------------------

Horrible. Could we replace some of this with INSTALL_TARGETS?
Attachment #720251 - Flags: review?(ted) → review+
Blocks: 847393
https://hg.mozilla.org/mozilla-central/rev/1166fdaf0fde
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla22
Mike, should we uplift this to aurora?
It sure wouldn't hurt.
Comment on attachment 720251 [details] [diff] [review]
Fix NSINSTALL in res/drawable-mdpi/icon.png rule

[Approval Request Comment]
Bug caused by (feature/regressing bug #): typo in mobile/android/base/Makefile.in
User impact if declined: Random build errors on android builds
Testing completed (on m-c, etc.): Landed on m-c
Risk to taking this patch (and alternatives if risky): None
String or UUID changes made by this patch: None
Attachment #720251 - Flags: approval-mozilla-aurora?
Comment on attachment 720251 [details] [diff] [review]
Fix NSINSTALL in res/drawable-mdpi/icon.png rule

low risk patch, helps avoid build errors.Approving for uplift.
Attachment #720251 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.