Incorrect link provided in output when running bedrock server

RESOLVED DUPLICATE of bug 816080

Status

RESOLVED DUPLICATE of bug 816080
6 years ago
6 years ago

People

(Reporter: caseybecking, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130215130331

Steps to reproduce:

running $  ./manage.py runserver in bedrock


Actual results:

The error coming back is 
/Library/WebServer/Documents/mozilla/bedrock/vendor/src/funfactory/funfactory/manage.py:47: UserWarning: You're using an old-style Playdoh layout with a top level __init__.py and apps directories. This is error prone and fights the Zen of Python. See http://playdoh.readthedocs.org/en/latest/upgrading.html.
  warnings.warn("You're using an old-style Playdoh layout with a top "



Expected results:

The link 
http://playdoh.readthedocs.org/en/latest/upgrading.html

Should be
http://playdoh.readthedocs.org/en/latest/getting-started/upgrading.html
This is actually a result of bedrock using a really old version of playdoh-lib/funfactory.

The commit which fixed this: https://github.com/mozilla/funfactory/commit/2fcb61d0.

The bug to upgrade playdoh used by bedrock: bug 816080 and the WIP pull request: https://github.com/mozilla/bedrock/pull/558
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 816080
You need to log in before you can comment on or make changes to this bug.