when opening multiple tabs at the same time, images are fully or partially blank

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
5 years ago
3 years ago

People

(Reporter: Vittorio Giovara, Unassigned)

Tracking

19 Branch
x86_64
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 720346 [details]
A broken image, blank for the lenght of the window height

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130215130331

Steps to reproduce:

I like to read webcomics so I collect the ones I like more in a folder in the bookmark bar. I usually hit the "Open all in tabs" and let all the websites load in the background. This is something that caused no problem until version < 18.

Tested only on OS X 10.6.8.


Actual results:

Completely randomly, some images of the webcomics are left unloaded, blank space. Then if I scroll down and then up, the image appears; if there is too little space to scroll I select all and the image appears. Sometimes the image is blank for the whole height of the page and when I scroll down the remaining portion appears (and when I scroll up, the full image appears).
The image is restored not only when I scroll, but also when I leave Firefox window and select another open application (this has given me some fun times in taking the screenshot too).

Needless to say I tried this with my add-ons enabled and disabled, with the same result.


Expected results:

If I load each website one by one no problem appears. However this is what should have happened when loading multiple tabs (and what happened until version < 18).
(Reporter)

Comment 1

5 years ago
(screenshot source is http://www.lario3.blogspot.it/)
Hardware: x86 → x86_64

Comment 2

5 years ago
May be related to bug 128956 or bug 545351.

Does it depend on whether hardware acceleration is enabled (Preferences → Advanced)?
(Reporter)

Comment 3

5 years ago
I had hardware acceleration when I noticed this.

With hardware acceleration DISABLED I cannot actually reproduce this bug any more.

Comment 4

5 years ago
FWIW, he reports that his machine has 256MiB of vRAM.  Don't know what gfx card.
I imagine OSX, being composited, and w/ various fancy effects and views, probably uses a decent chunk of that.

Comment 5

3 years ago
Hi,

I tested this on Nightly 46.0a1 and I can't reproduce this on Mac Os X 10.10. 
Reporter do you still have this issue? Please retest this using the latest version of Firefox, download it from here: https://www.mozilla.org/en-US/firefox/new/
Thank you very much for your help.
Flags: needinfo?(vitto.giova)
(Reporter)

Comment 6

3 years ago
Not really, I changed OS version, hardware and several FF releases, so it can't be reproduced...
Flags: needinfo?(vitto.giova)

Comment 7

3 years ago
Thank you for your feedback. Based on comment 6 this bug will be marked as resolved WFM.
Please reopen it if you still reproduce this issue on the latest version.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.