bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

[Dialer] During calling, select keypad and input number, and press home key, statusbar contains the number entered by the user

RESOLVED FIXED

Status

Firefox OS
Gaia::Dialer
--
critical
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Leo, Assigned: iliu@mozilla.com, ianliu.moz@gmail.com)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18 fixed)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Created attachment 720544 [details]
Screenshots.zip

1. Title : During calling, select keypad and input number, and press home key, statusbar contains the number entered by the user
2. Precondition : In call >> Select dial pad >> Input number
3. Tester's Action : Press Home key
4. Detailed Symptom : Statusbar contains the number entered by user
5. Expected : Statusbar contains caller's number
6. Reproducibility: Y
1) Frequency Rate : 100%
7. Gaia revision :
(Reporter)

Comment 1

5 years ago
Created attachment 725352 [details]
Pull request pointer


I have fixed this issue. 
Pull request pointer: https://github.com/mozilla-b2g/gaia/pull/8675

Please review
Attachment #725352 - Flags: review?(etienne)
(Reporter)

Updated

5 years ago
Assignee: nobody → leo.bugzilla.gaia
Comment on attachment 725352 [details]
Pull request pointer

I think the |onresize| support could be part of the |CallScreen|, this way we won't use the |_typedNumber| "private" variable outside of the |CallScreen|.

You could add the listener in the |init| function of the |CallScreen|.

Also please be sure to "make lint", this patch contains linting issues.

Thanks!
Attachment #725352 - Flags: review?(etienne)
(Reporter)

Comment 3

5 years ago
I have shifted the code inside CallScreen which is as folows 
var CallScreen = {


 /*added code */
 resize: function as_resize(evt) {
      //resize code
    }
  },
 

 init: function cs_init() {

     //added code
   window.onresize = this.resize;
 },

}
 Is this OK ? 
 ( Will upload the same patch if the written thing is not clear for review   )
Flags: needinfo?(etienne)
(In reply to leo.bugzilla.gaia from comment #3)
> I have shifted the code inside CallScreen which is as folows 
> var CallScreen = {
> 
> 
>  /*added code */
>  resize: function as_resize(evt) {
>       //resize code
>     }
>   },
>  
> 
>  init: function cs_init() {
> 
>      //added code
>    window.onresize = this.resize;
>  },
> 
> }
>  Is this OK ? 
>  ( Will upload the same patch if the written thing is not clear for review  
> )

Sounds good!
Flags: needinfo?(etienne)
(Reporter)

Updated

5 years ago
blocking-b2g: --- → leo?

Updated

5 years ago
blocking-b2g: leo? → leo+
(Reporter)

Updated

5 years ago
Assignee: leo.bugzilla.gaia → nobody
(Reporter)

Updated

5 years ago
Assignee: nobody → leo.bugzilla.gaia
I would like to take over the issue since it's leo+ status without updating 3 weeks.
Assignee: leo.bugzilla.gaia → iliu
Created attachment 753168 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/9946

Pointer to Github pull-request
Comment on attachment 753168 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/9946

If a user is typing keypad during calling, we don't show the typed number in status bar mode.

Etienne,

Could you please help to review my pr? Thank you.
Attachment #753168 - Flags: review?(etienne)
Comment on attachment 753168 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/9946

Thanks for picking this up

r=me on 3f0caa8d567d3c8ae668456092a0cac53ee3e9f9
Attachment #753168 - Flags: review?(etienne) → review+
Thanks for Etienne's reviewing effort. Since the pr is landed in master/v1-train, we can close the issue now.

master:   b60033a071db7d9af1e2da55ff6bcb8de3ed03d9
v1-train: 71c3bcdb758324442a5c72fcd24c09cf219c564c
Status: NEW → RESOLVED
Last Resolved: 5 years ago
status-b2g18: --- → fixed
Resolution: --- → FIXED

Updated

5 years ago
Flags: in-moztrap?

Updated

5 years ago
Flags: in-moztrap? → in-moztrap+
QA Contact: amiller
You need to log in before you can comment on or make changes to this bug.