<select> raises 'onchange' event if the 1st <option> is disabled and selected although user selected nothing

RESOLVED DUPLICATE of bug 346043

Status

()

Core
General
RESOLVED DUPLICATE of bug 346043
5 years ago
5 years ago

People

(Reporter: Roman Orazmagomedov, Unassigned)

Tracking

19 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 720546 [details]
test.html

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130215130331

Steps to reproduce:

There is <select> with disabled and selected <option>.
1. Click on <select> and move mouse cursor over any enabled <option>, but not select it.
2. Move mouse cursor horizontally outside of <select>
3. Click anywhere on the page.
4. Click on any other window.


Actual results:

After the 3-rd action nothing happens.
After the 4-th action 'onchange' event is raised for <select>.


Expected results:

Nothing must happen after any action.

Comment 1

5 years ago
I tried looking for a regression, but this happens in nightlies going back to 2008.

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 346043
You need to log in before you can comment on or make changes to this bug.