Mail send fails to complete when SSL set to "When Available"

VERIFIED FIXED in mozilla0.9.2

Status

MailNews Core
Backend
P1
blocker
VERIFIED FIXED
17 years ago
9 years ago

People

(Reporter: tracy, Assigned: Scott MacGregor)

Tracking

Trunk
mozilla0.9.2
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta1+][PDT+])

Attachments

(3 attachments)

(Reporter)

Description

17 years ago
seen on commercial builds:

windows 2001-06-08-06-trink
mac 2001-06-08-01-trunk

note: linux 2001-06-08-09-trunk is okay

-Compose a mail message (in pop or imap, plain text or html) 
-Send the messaage

the status bar spins perpetually "sending message"

the message is never sent
(Reporter)

Updated

17 years ago
Keywords: smoketest

Comment 1

17 years ago
Tracy, do you see this only on today's builds or do you see this on yesterday's
build or a 4.7 build?  I'm asking because I've been seeing this on a branch
build from a couple of days ago when it didn't used to happen.  I'm wondering if
there's some kind of server problem or bad interaction between our client and
the smtp server.  reassigning to ducarroz and cc'ing varada.
Assignee: mscott → ducarroz
(Reporter)

Comment 2

17 years ago
I am able to send messages from 4.x on the same machines taht the smoketests for 
the commercial builds were performed on.  There seems to be alot of network 
problems today.  I am sure it's possible that's allthis is...but I wonder why 
linux commercial works and not this.  granrose believes that perhaps the cvs 
problem this morning prevented linux builds from getting ther changes from last 
night.  Loan is respinning linux builds now.

Comment 3

17 years ago
I logged similar bug yesterday (see bug 84534) but after I  remove profiles, 
mozregistry.dat & mozver.dat files and reboot my system - it's working again. 
don't know it matter or not!!
I don't have problem sending mail! Does anybody else have the problem?
Tracy, can you delete your registry and try again.
Status: NEW → ASSIGNED

Comment 5

17 years ago
FYI, this is happening using the 6/6 0.9.1 build too.  Multiple times I haven't
been able to send an email the very first time but then when it comes back with
Send Failed, I try again and it works.  Though the last 4 or so mails I've sent
have worked without a problem.

Comment 6

17 years ago
I am seeing this on MSW2000 Build 2001060804.

Sendmail Sez: 
Jun  8 14:24:32 sdcorp sendmail[13229]: NOQUEUE: sdcorp.net [66.47.89.226] (may
be forged) did not issue MAIL/EXPN/VRFY/ETRN during connection to MTA.


Comment 7

17 years ago
Mai Mai Tsai has been having this problem with the beta1 cantidate bits. I'm 
adding her to the CC: list for her to comment.

Comment 8

17 years ago
Fails on Mac Commerical build 2001060808 also. Mozilla tree still building...
(Reporter)

Comment 9

17 years ago
VARADA -"After several moments of stupidity I have found the problem - SSL When 
available strikes again. I forget the existing bug on this and will leave it to 
someone else."
I thought the SSL problem was fixed!
(Reporter)

Comment 11

17 years ago
verified on the mac build too that ssl not set to never is the problem

Comment 12

17 years ago
This might be the dup of #74387 assigned to jgmyers. Reassigning bug to mscott
as requested and removing smoketest blocker since there is a workaround.
Assignee: ducarroz → mscott
Status: ASSIGNED → NEW
Keywords: smoketest

Updated

17 years ago
Summary: Mail send fails to complete → Mail send fails to complete: SSL problem?
(Assignee)

Comment 13

17 years ago
Okay, I'm tired of this pref setting repeatedly biting us in the butt. I don't
agree with the default setting of "try SSL when available". I'm going to invoke
the wrath of John and attempt to change our behavior to the 4.x behavior which
is to default to "never use SSL" and allow the user to choose to try ssl. Of
course we still need to find the cause of the regression that broke "try ssl" again.

Comment 14

17 years ago
I agree we should change the setting.  Those who care about SSL will change it.
(Assignee)

Comment 15

17 years ago
Created attachment 37718 [details] [diff] [review]
diff to reset the default value to never use SSL for smtp
(Assignee)

Comment 16

17 years ago
This patch reverses the change to default all SMTP servers to "Try SSL when
available" back to the original behavior of "Never try SSL".

Note: this only works for new profiles. It won't change the setting on existing
profiles. 
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.2

Comment 17

17 years ago
*** Bug 84875 has been marked as a duplicate of this bug. ***

Comment 18

17 years ago
I also got this problem on Linux w/ build 2001060721.

The weird thing is that it seems to block all the networking part
of mozilla : when moz tries to send the mail,
I go on an opened browser window, and try to load a page :
there is absolutely no network activity (as I can see using tcpdump).
See attachment for what I get on the console output of Mozilla.

Setting SSL to never and de-selecting "Use name and password"
seems to correct the problem (the mail is sent correctly).

Note that this bug seems to be related to bug 79391.

Comment 19

17 years ago
Created attachment 37793 [details]
The output I get when trying to send a mail w/ "Try SSL"

Comment 20

17 years ago
In addition to making the pref Never by default, we need to fix the actual bug,
so I'm changing the summary.   
Keywords: nsbeta1
Priority: -- → P1
Summary: Mail send fails to complete: SSL problem? → Mail send fails to complete when SSL set to "When Available"
Whiteboard: [nsbeta1+]

Comment 21

17 years ago
*** Bug 85098 has been marked as a duplicate of this bug. ***

Comment 22

17 years ago
Win2000 build 20010610xx also has this problem.
I didn't try if it is "SSL when available" or not.

Same situation as
------- Additional Comments From Thibault G. 2001-06-09 08:56 -------
The weird thing is that it seems to block all the networking part
of mozilla


Comment 23

17 years ago
adding PDT+
Whiteboard: [nsbeta1+] → [nsbeta1+][PDT+]
(Assignee)

Comment 24

17 years ago
*** Bug 85262 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 25

17 years ago
I've spun off Bug #85304 to track down the regression with the TLS socket used
by SMTP. Looks like the problem is in PSM who creates the TLS socket. I'm not
sure how they are able to block our networking threads though but that's
definetly what I'm seeing. 

I'll leave this bug alone as a tracking bug for making the default for new
profiles be "Never use SSL" instead of "use when available".
rs=sspitzer

Updated

17 years ago
Blocks: 83989
*** Bug 85338 has been marked as a duplicate of this bug. ***
*** Bug 85332 has been marked as a duplicate of this bug. ***

Comment 29

17 years ago
*** Bug 85497 has been marked as a duplicate of this bug. ***

Comment 30

17 years ago
a= asa@mozilla.org for checkin to the trunk.
(on behalf of drivers)

Comment 31

17 years ago
The default for new profiles should be "When Available."  Users shouldn't have 
to take extraordinary action in order to get the benefit of server features such 
as security or certificate authentication.
(Assignee)

Comment 32

17 years ago
Please mark future dups of this bug on 83989 which is the real problem here (psm
was no longer creating TLS connections properly).

Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 33

17 years ago
Do you mean trunk approval is the problem here? ;-)

Comment 34

17 years ago
There are currently no members of the crypto team on this cc list.  I'm adding some.

Comment 35

17 years ago
Start having this problem on Windows and Linux since 6-12 trunk build.
With 6-12 & 6-13 trunk builds on Windows and Linux, cann't send out mail at all.
Did clean installation and use default settings to start messenger. It fail 
always. But as soon as switching back to Beta build or
Communicator, sending mail works without any problem.
(Assignee)

Comment 36

17 years ago
yulian, you are running into Bug #85304. 

Comment 37

17 years ago
Works for 20010614 trunk builds now. Thank you for the FIX !!

Comment 38

17 years ago
Verifying it.
Status: RESOLVED → VERIFIED

Comment 39

17 years ago
*** Bug 86675 has been marked as a duplicate of this bug. ***

Comment 40

17 years ago
I use build 2001080303, I think this has regressed, but the problem is with big
messages
My setup is:
-IMAP server with SSL encryption
-Sent messages are copied to "sent" folder in the mailbox

To reproduce, I need to:
-Create a message
-Add some attachments to it (I added 3 images ~350 kb each)
-Fill in To: and Subject: lines
-Click send

Mozilla shows a modal send progress window. The bar goes to 99%, then stops. The
spinner in the composition window keeps spinning even if I close the send
progress window with its 'X' button.

Should the bug be reopened?

Comment 41

17 years ago
BTW, when I change SMTP option "Use secure connection" from "When available" to
"never", messages are sent successfully.

Comment 42

17 years ago
*** Bug 88303 has been marked as a duplicate of this bug. ***

Comment 43

17 years ago
Build: 2001 08 11 08
Win2K

I run into this problem on a daily basis, normally when forwarding emails to
other people.

Reopening.
Status: VERIFIED → REOPENED
Keywords: nsenterprise
Resolution: FIXED → ---

Comment 44

17 years ago
Created attachment 45590 [details]
snapshot of a frozen mail send
(Assignee)

Comment 45

17 years ago
Bob, your problem is a dup of 88303 which is a psm bug. Someone incorrectly
marked it a dup of this bug. 
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED

Comment 46

17 years ago
Verifying as nothing really changed since the bug was earlier verified for the
frst time.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.