Status

Tech Evangelism Graveyard
English US
VERIFIED INVALID
17 years ago
3 years ago

People

(Reporter: zaitcev, Assigned: bc)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
The page comes out blank (same as in relase 0.9).
I'll try to attach the page to the bug.
(Reporter)

Comment 1

17 years ago
Created attachment 37680 [details]
Page that shows blank
(Reporter)

Comment 2

17 years ago
Release 0.9 was silent, the 0.9.1 prints:
Document file:///q/zaitcev/tmp/3com-query-mozbug.html loaded successfully

Comment 3

17 years ago
If you take out the extra --'s in the middle of the comments, it displays fine.
See bug 79139 for a similar problem.  I don't know if mozilla is choosing the
correct mode, strict or quirks for this page.
(Reporter)

Comment 4

17 years ago
I am sorry to tell that I cannot figure how to know
what mode the renderer selected (strict or quirks).
Page info window does not tell, and enabling any
debugging did not help.

Comment 5

17 years ago
->Evangelism
Assignee: asa → bclary
Status: UNCONFIRMED → NEW
Component: Browser-General → Evangelism
Ever confirmed: true
QA Contact: doronr → zach
Actually, this is just invalid, since we don't have a URL to evangelize...

HTML comments in strict mode (which this is parsed in, since it has a 4.01
transitional doctype with URI) are delimeted by --.  -- starts the comment and
-- ends it.  So:

<!-- commented -- not commented but part of SGML markup, so not shown -->
commented, since the dash-dash started a comment and then the > was ignored<!--
not commented but part of SGML markup -->  commented
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 7

17 years ago
yep
Status: RESOLVED → VERIFIED
(Reporter)

Comment 8

17 years ago
I suppose you refer to
http://www.w3.org/TR/html401/intro/sgmltut.html
clause 3.2.4
(Assignee)

Comment 10

17 years ago
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Version: other → unspecified
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.