[BB][input_areas] - Input text should be aligned with header

RESOLVED FIXED

Status

RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: epang, Assigned: pivanov)

Tracking

({polish})

unspecified
All
Other
polish
Dependency tree / graph

Firefox Tracking Flags

(b2g18+ fixed)

Details

(Whiteboard: visual design, UX-P1, yedo, uxbranch, landed in uxbranch)

Attachments

(3 attachments)

(Reporter)

Description

6 years ago
Created attachment 720771 [details]
Input Area text should be left aligned with header

Text in input fields should be aligned with the header (30px left margin)
Created attachment 722950 [details]
Before-After
Created attachment 722952 [details]
patch for Gaia repo
Attachment #722952 - Flags: review?(sjochimek)
(Reporter)

Comment 3

6 years ago
(In reply to Pavel Ivanov [:ivanovpavel] from comment #1)
> Created attachment 722950 [details]
> Before-After

Text alignment looks good now.  But why did 'account type' change?  It should go back to being a subheading as it was in your first patch. Thanks!
Flags: needinfo?(pivanov)
Oh ... my mistake ... I just put the screenshot image on wrong place(in the middle) I will update the image later.
Flags: needinfo?(pivanov)
Actualy the image is correct ... The "Account type" is fixed in Bug 844978
(Reporter)

Comment 6

6 years ago
(In reply to Pavel Ivanov [:ivanovpavel] from comment #5)
> Actualy the image is correct ... The "Account type" is fixed in Bug 844978

ok, thanks for letting me know.  This is good then :).
(Reporter)

Updated

6 years ago
blocking-b2g: --- → leo?
(Reporter)

Comment 7

6 years ago
Part of LG's request for font updates.
Mass edit to set tracking-b2g18+ for these UX bugs that were called out for v1.1
tracking-b2g18: --- → +

Updated

6 years ago
blocking-b2g: leo? → ---

Updated

6 years ago
Attachment #722952 - Flags: review?(sjochimek) → review+

Comment 9

6 years ago
https://github.com/mozilla-b2g/gaia/commit/cd9e439a33caba739cf4789ed64728ed067d2017
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Should this get uplifted to v1.1 or is too risky ?

Updated

6 years ago
Whiteboard: visual design, UX-P1, yedo → visual design, UX-P1, yedo, uxbranch, landed in uxbranch
I noticed that email and several other apps are still not fixed even though you fixed the building block, should I file individual bugs for individual apps?  or should I file one bug in regards the other apps?

Updated

6 years ago
Flags: needinfo?(pivanov)

Updated

6 years ago
status-b2g18: --- → affected
We should open separate bugs for each app because the implementation of the [BB] is different ... and it's related to the layout of each app (e.g the left margins/paddings of the inputs are different for each app)
Flags: needinfo?(pivanov)

Updated

6 years ago
Depends on: 858697
(Reporter)

Comment 13

6 years ago
(In reply to Pavel Ivanov [:ivanovpavel] from comment #12)
> We should open separate bugs for each app because the implementation of the
> [BB] is different ... and it's related to the layout of each app (e.g the
> left margins/paddings of the inputs are different for each app)

Hi Pavel, are the headers (text) not positioned 30px on each app?
Flags: needinfo?(pivanov)
And my comment 10 was not answered...
(Reporter)

Comment 15

6 years ago
(In reply to Julien Wajsberg [:julienw] from comment #14)
> And my comment 10 was not answered...

Pavel, based on Julien's comment, if it's always 30px left padding for text in input fields would this be risky to uplift to v1.1?
(In reply to Julien Wajsberg [:julienw] from comment #10)
> Should this get uplifted to v1.1 or is too risky ?

Sorry for the delay Julien .. I think the risk is very low ... I made only few css adjustments
Flags: needinfo?(pivanov)
(Reporter)

Comment 17

6 years ago
Hi Sergiy,

Wanted to loop you into this bug as well.  We've proposed having all input text left align with the header (at 30px). With the text all aligned we find everything looks more oragnized and clean.

Wanted to make sure you agree before this bug moves forward. Let us know your thoughts on this.  Thanks!
Flags: needinfo?(sergiov)

Comment 18

6 years ago
Yes, that's correct. We should use a left padding of 30px for the input text, while the input field should have a 15px padding. 

Looks perfect to me.

Thanks!
Flags: needinfo?(sergiov)
Comment on attachment 722952 [details]
patch for Gaia repo

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): -
User impact if declined: unpleasant layout
Testing completed: yes, this is in master for 1,50 months.
Risk to taking this patch (and alternatives if risky): very low, only small css changes. The worst impact is that some text could be moved by a few pixels.
String or UUID changes made by this patch: none
Attachment #722952 - Flags: approval-gaia-v1?(21)
(Reporter)

Comment 20

6 years ago
(In reply to Sergi from comment #18)
> Yes, that's correct. We should use a left padding of 30px for the input
> text, while the input field should have a 15px padding. 
> 
> Looks perfect to me.
> 
> Thanks!

great thanks Sergi!
Attachment #722952 - Flags: approval-gaia-v1?(21) → approval-gaia-v1+
Uplifted cd9e439a33caba739cf4789ed64728ed067d2017 to:
v1-train: 06153e130a98ac0179df460c5d741e152fc5d4b5
status-b2g18: affected → fixed
You need to log in before you can comment on or make changes to this bug.