If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Built-in PDF viewer is not showing bookmark view by default when the PDF is saved to display the bookmark panel upon opening.

RESOLVED DUPLICATE of bug 837647

Status

()

Firefox
PDF Viewer
P3
normal
RESOLVED DUPLICATE of bug 837647
5 years ago
5 years ago

People

(Reporter: beerninja, Unassigned)

Tracking

19 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [pdfjs-c-ux])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130215130331

Steps to reproduce:

Open a PDF file that was saved with the bookmark panel enabled by default.
Example Onkyo owner's manual:
http://63.148.251.135/redirect_service.cfm?type=own_manuals&file=TX-NR818_English.pdf


Actual results:

In Firefox 19's built-in PDF viewer, opening a PDF file that was saved with the bookmark panel view enabled does not show the bookmark panel by default.  Also I was not able to collapse/expand the bookmark subsections.


Expected results:

Bookmark view should have shown up by default as it does with nearly every other PDF viewer.  I work in customer service and I am getting calls from non-tech savvy people complaining about having to navigate a 300+ page document with their mouse wheel.  Apparently they were smart enough to install Firefox but not smart enough to learn how to enable the bookmark panel manually.  Please rectify this as soon as possible, I'm sure it is affecting customer service departments globally!
(Reporter)

Updated

5 years ago
Severity: normal → major
Component: Untriaged → PDF Viewer

Updated

5 years ago
Severity: major → normal
Priority: -- → P3
Whiteboard: [pdfjs-c-ux]

Comment 1

5 years ago
Created attachment 726613 [details]
Sample PDF which illustrates this bug

This bug affects all of the online journals of the American Mathematical Society. We have reproduced it in Windows, MacOS and Linux. 

For our journal article PDFs, we have set (internally in the PDF file) the default view upon opening to include the sidebar with navigation (bookmarks) visible. This default setting in the file is ignored by the Firefox PDF viewer, although it is recognized by all viewers described above. 

A sample journal article is attached. When opened in Adobe Reader or xpdf (pdf viewer for X11), it opens with the sidebar visible and bookmarks displayed in the sidebar. This "default view" is indicated internally in the PDF file but is ignored by the Firefox internal PDF viewer.

This is one of the bugs which was reported in bug 852156, for which it was requested that we file each of the reported bugs as a separate bug report.
(Reporter)

Updated

5 years ago
OS: Windows XP → All
Hardware: x86 → All

Comment 2

5 years ago
I think this bug is a duplicate of bug #837647.
(Reporter)

Comment 3

5 years ago
You are right, thanks shimazu
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 837647
You need to log in before you can comment on or make changes to this bug.