Closed Bug 847561 Opened 12 years ago Closed 12 years ago

[traceback] TypeError: expected string or buffer

Categories

(Marketplace Graveyard :: Payments/Refunds, defect, P1)

defect

Tracking

(Not tracked)

RESOLVED WORKSFORME
2013-03-14

People

(Reporter: krupa.mozbugs, Assigned: andy+bugzilla)

References

Details

(Whiteboard: p=2)

steps to reproduce:
1. Start a purchase of a paid app
2. Log in using Identity

observed behavior:
After log in, the error page "Something went wrong!" page loads since there is an Internal Server Error @ /mozpay/

traceback:
Stacktrace (most recent call last):

  File "django/core/handlers/base.py", line 117, in get_response
    response = middleware_method(request, e)
  File "webpay/base/middleware.py", line 31, in process_exception
    json.loads(exception.content)))
  File "json/__init__.py", line 307, in loads
    return _default_decoder.decode(s)
  File "json/decoder.py", line 319, in decode
    obj, end = self.raw_decode(s, idx=_w(s, 0).end())

sentry: http://sentry.dmz.phx1.mozilla.com/amo-ops/marketplace-dev-webpay/group/12000/
Assignee: nobody → amckay
Priority: -- → P1
Whiteboard: p=2
Version: 1.1 → 1.2
Blocked until I can test effectively and get bango to text me or someone can help me and get texts.
Can't reproduce.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.