bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Hide infrequently used options on release kickoff form

RESOLVED DUPLICATE of bug 835336

Status

Release Engineering
Release Automation: Other
RESOLVED DUPLICATE of bug 835336
5 years ago
5 years ago

People

(Reporter: nthomas, Assigned: massimo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [shipit])

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

5 years ago
Things like the promptWaitTime for updates aren't used that often, and as we add more (eg 'actions   silent' to suppress the What's New page) the form could get unwieldy. We could hide them by default in the form, and have some sort of 'Show Advanced Options' button to unhide.
Relbranches could go here too.
(Assignee)

Comment 2

5 years ago
(In reply to Ben Hearsum [:bhearsum] from comment #1)
> Relbranches could go here too.

It should be easy to show/hide columns with few lines of javascript (jquery is already in static/ )
(Assignee)

Comment 3

5 years ago
Created attachment 721240 [details] [diff] [review]
javascript function to hide/show columns
Attachment #721240 - Flags: feedback?(bhearsum)
Comment on attachment 721240 [details] [diff] [review]
javascript function to hide/show columns

Review of attachment 721240 [details] [diff] [review]:
-----------------------------------------------------------------

The javascript parts are fine, but we actually want to do this on submit_release.html, not on releases.html. I think it would also be good to move those parts of the form to the bottom, below l10n changesets but above the submit button.
Attachment #721240 - Flags: feedback?(bhearsum) → feedback+
Assignee: nobody → mgervasini
(Assignee)

Comment 5

5 years ago
Created attachment 721749 [details] [diff] [review]
added button to hide/show advanced fields in submit_release

Added a button at the top of the page to switch between basic and advanced options. Basic options are active by default. 
Moved 'advanced' fields at the bottom of the form.
Attachment #721240 - Attachment is obsolete: true
Attachment #721749 - Flags: review?(bhearsum)
Comment on attachment 721749 [details] [diff] [review]
added button to hide/show advanced fields in submit_release

Review of attachment 721749 [details] [diff] [review]:
-----------------------------------------------------------------

This is mostly fine, just a couple of things I'd like to see changed:
* Comm relbranch should be an advanced field, too. (Only applies to Thunderbird)
* It'd be nice to have some sort of visual separator (maybe as simple as a horizontal rule) between the basic and advanced fields.
Attachment #721749 - Flags: review?(bhearsum) → feedback+
(Assignee)

Comment 7

5 years ago
Created attachment 722194 [details] [diff] [review]
added separator (from css), moved Comm relbranch into advanced

* added <div class='advanced'> to hide/show advanced elements: all the elements that should not be displayed in the basic view must be child of this element
* Comm Relbranch for thunderbird is now a child of <div class='advanced'>
* added .advanced in kickoff.css
* updated toggle() with fadeToggle() in javascript section
Attachment #721749 - Attachment is obsolete: true
Attachment #722194 - Flags: review?(bhearsum)
Comment on attachment 722194 [details] [diff] [review]
added separator (from css), moved Comm relbranch into advanced

Review of attachment 722194 [details] [diff] [review]:
-----------------------------------------------------------------

This is 99% there, just a couple small style nits:
* The button text should be "Show Advanced Options" or "Hide Advanced Options".
* On my laptop, the layout overflows for Thunderbird's comm relbranch, which makes it difficult to read: https://people.mozilla.com/~bhearsum/sattap/f3ccd8ca.png

r=me with those fixed.
Attachment #722194 - Flags: review?(bhearsum) → feedback+
(Assignee)

Comment 9

5 years ago
(In reply to Ben Hearsum [:bhearsum] from comment #8)
> Comment on attachment 722194 [details] [diff] [review]
> added separator (from css), moved Comm relbranch into advanced
> 
> Review of attachment 722194 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> This is 99% there, just a couple small style nits:
> * The button text should be "Show Advanced Options" or "Hide Advanced
> Options".
> * On my laptop, the layout overflows for Thunderbird's comm relbranch, which
> makes it difficult to read:
> https://people.mozilla.com/~bhearsum/sattap/f3ccd8ca.png
> 
> r=me with those fixed.

Ben, I have fixed the button text but I cannot reproduce the layout overflow.
This is getting fixed as part of bug 835336.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 835336
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.