Status

()

defect
VERIFIED FIXED
6 years ago
3 years ago

People

(Reporter: nrbelex, Assigned: bnicholson)

Tracking

({regression})

20 Branch
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox20 verified, firefox21 verified, firefox22 unaffected)

Details

Attachments

(2 attachments)

Reporter

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130215130331

Steps to reproduce:

With a website loaded in a tab, I hit the tab counter in the top right. 

On Aurora 21.0a2 2013-03-04.


Actual results:

The top bar with icons delineating tabs, private tabs ans synced tabs has a duplicate set of identical buttons to the right which don't do anything. See screenshot attached.


Expected results:

Single set of icons should appear.
Reporter

Updated

6 years ago
OS: Windows 7 → Android
Hardware: x86_64 → ARM
Wild, havn't seen this. Sriram, any thoughts?

Brett, which phone is that?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Reporter

Comment 2

6 years ago
Galaxy SII derivative: Samsung SPH-D710 (Epic 4G Touch) with Android 4.04.
Duplicate of this bug: 847674
tracking-fennec: --- → ?
Regression from bug 845511:
https://hg.mozilla.org/releases/mozilla-aurora/rev/d18a62362aab

The patches that landed on Aurora and Beta were incomplete, and did not remove the previous addTab calls:
https://hg.mozilla.org/releases/mozilla-aurora/rev/d18a62362aab#l1.34

Updated

6 years ago
Version: Firefox 21 → Firefox 20
Duplicate of this bug: 847802
Assignee

Comment 6

6 years ago
[Approval Request Comment]
Regression caused by (bug #): uplifting bug 845511; lines from m-c patch didn't make uplift
User impact if declined: duplicate tabs tray tabs (see screenshot)
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): very low risk
Assignee: nobody → bnicholson
Attachment #721119 - Flags: review?(mark.finkle)
Attachment #721119 - Flags: approval-mozilla-release?
Attachment #721119 - Flags: approval-mozilla-beta?
Comment on attachment 721119 [details] [diff] [review]
Add lines missing from uplift

Note to others: This patch should only be used on Aurora and Beta
Attachment #721119 - Flags: review?(mark.finkle) → review+
(In reply to Brian Nicholson (:bnicholson) from comment #6)
Uplift to Aurora instead of Release?
Comment on attachment 721119 [details] [diff] [review]
Add lines missing from uplift

[Approval Request Comment]
See above
Attachment #721119 - Flags: approval-mozilla-release? → approval-mozilla-aurora?
Assignee

Comment 10

6 years ago
Comment on attachment 721119 [details] [diff] [review]
Add lines missing from uplift

This was already approved and just adds the missing lines, so I'll land the fix now.
Attachment #721119 - Flags: approval-mozilla-beta?
Attachment #721119 - Flags: approval-mozilla-aurora?
Thanks for fixing this, and I am terribly sorry for the mess-up of that uplift!

Updated

6 years ago
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Duplicate of this bug: 848275
Unable to reproduce the issue on Aurora 21.0a2 2013-03-14 or Firefox Mobile 20 beta 5 on the Samsung Galaxy S2 (Android 4.0.3)
Status: RESOLVED → VERIFIED
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.