puppet manifests for running hg/git conversions continually on boot

RESOLVED DUPLICATE of bug 927199

Status

Release Engineering
General Automation
P3
normal
RESOLVED DUPLICATE of bug 927199
5 years ago
3 years ago

People

(Reporter: aki, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: 799719)

(Reporter)

Description

5 years ago
Ideally this means we point a clean box at puppet, and it installs everything needed and starts up whatever processes are needed to run the conversion processes at boot.

Currently we use screen and manual setup; this needs to be automatic.

_ figure out way to run continuously without screen (cron-based; daemon based?)
_ figure out how to start automatically on boot

I'm not sure how we'll spawn off multiple processes and split them up so we take advantage of all cores... something like httpd spawning N child processes up to some configurable limit?  Manually splitting and balancing jobs into N config files?

We may need to split across multiple machines as well, so we'd need to make sure each repo is covered by exactly one of those machines.
(Assignee)

Updated

4 years ago
Product: mozilla.org → Release Engineering
Is this still an issue with the new vcs sync software?
Flags: needinfo?(aki)
(Reporter)

Comment 2

4 years ago
Yes, vcssync{1,2} were built by hand.
Flags: needinfo?(aki)
(Reporter)

Comment 3

4 years ago
vcssync{3,4} puppetized is bug 927199; let's track this in there.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 927199
You need to log in before you can comment on or make changes to this bug.