TEST-UNEXPECTED-FAIL | addon-sdk/tests/test-xul-app.test xulapp

RESOLVED INCOMPLETE

Status

Add-on SDK
General
P1
normal
RESOLVED INCOMPLETE
5 years ago
5 months ago

People

(Reporter: KWierso, Assigned: erikvold)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
I'm seeing this intermittently on Win Debug builds in TBPL. Not sure what it means other than Win Debug builds being horribly slow, but filing to track it anyway.

https://tbpl.mozilla.org/php/getParsedLog.php?id=20311122&tree=Jetpack&full=1

TEST-UNEXPECTED-FAIL | tests/test-xul-app.test satisfies version range | Test run exceeded timeout (1800s).

Traceback (most recent call last):

  File "bin/cfx", line 33, in <module>

    cuddlefish.run()

  File "C:\talos-slave\test\addonsdk-poller\addon-sdk-bce9c573ed1e\python-lib\cuddlefish\__init__.py", line 611, in run

    test_all(env_root, defaults=options.__dict__)

  File "C:\talos-slave\test\addonsdk-poller\addon-sdk-bce9c573ed1e\python-lib\cuddlefish\__init__.py", line 391, in test_all

    test_all_packages(env_root, defaults)

  File "C:\talos-slave\test\addonsdk-poller\addon-sdk-bce9c573ed1e\python-lib\cuddlefish\__init__.py", line 484, in test_all_packages

    env_root=env_root)

  File "C:\talos-slave\test\addonsdk-poller\addon-sdk-bce9c573ed1e\python-lib\cuddlefish\__init__.py", line 928, in run

    bundle_sdk=options.bundle_sdk)

  File "C:\talos-slave\test\addonsdk-poller\addon-sdk-bce9c573ed1e\python-lib\cuddlefish\runner.py", line 746, in run_app

    RUN_TIMEOUT, test_name, parseable)

Exception: Test run exceeded timeout (1800s).

TinderboxPrint:Jetpack<br/>163/0



https://tbpl.mozilla.org/php/getParsedLog.php?id=20311040&tree=Jetpack&full=1

TEST-UNEXPECTED-FAIL | tests/test-xul-app.test xulapp | Test run exceeded timeout (1800s).

Traceback (most recent call last):

  File "bin/cfx", line 33, in <module>

    cuddlefish.run()

  File "C:\talos-slave\test\addonsdk-poller\addon-sdk-bce9c573ed1e\python-lib\cuddlefish\__init__.py", line 611, in run

    test_all(env_root, defaults=options.__dict__)

  File "C:\talos-slave\test\addonsdk-poller\addon-sdk-bce9c573ed1e\python-lib\cuddlefish\__init__.py", line 391, in test_all

    test_all_packages(env_root, defaults)

  File "C:\talos-slave\test\addonsdk-poller\addon-sdk-bce9c573ed1e\python-lib\cuddlefish\__init__.py", line 484, in test_all_packages

    env_root=env_root)

  File "C:\talos-slave\test\addonsdk-poller\addon-sdk-bce9c573ed1e\python-lib\cuddlefish\__init__.py", line 928, in run

    bundle_sdk=options.bundle_sdk)

  File "C:\talos-slave\test\addonsdk-poller\addon-sdk-bce9c573ed1e\python-lib\cuddlefish\runner.py", line 746, in run_app

    RUN_TIMEOUT, test_name, parseable)

Exception: Test run exceeded timeout (1800s).

TinderboxPrint:Jetpack<br/>163/0



https://tbpl.mozilla.org/php/getParsedLog.php?id=20313127&tree=Jetpack&full=1

https://tbpl.mozilla.org/php/getParsedLog.php?id=20333219&tree=Jetpack&full=1

https://tbpl.mozilla.org/php/getParsedLog.php?id=20333182&tree=Jetpack&full=1

Comment 1

5 years ago
(Adding keyword since that's what TBPL uses to find bug suggestions to display in the TBPL UI)
Keywords: intermittent-failure
(Reporter)

Updated

5 years ago
Priority: -- → P2
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 866323
Blocks: 1111478
Priority: P2 → P1
Summary: TEST-UNEXPECTED-FAIL | tests/test-xul-app.test xulapp | Test run exceeded timeout (1800s). → TEST-UNEXPECTED-FAIL | addon-sdk/tests/test-xul-app.test xulapp
Comment hidden (Treeherder Robot)
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Hmm this may have something to do with the fact that xulapp is the last test.
Created attachment 8613849 [details] [review]
Link to Github pull-request: https://github.com/mozilla/addon-sdk/pull/1982
Attachment #8613849 - Flags: review?(dtownsend)
Assignee: nobody → evold
Attachment #8613849 - Flags: review?(dtownsend) → review+

Comment 20

3 years ago
Commits pushed to master at https://github.com/mozilla/addon-sdk

https://github.com/mozilla/addon-sdk/commit/c4e20e23b1470f76894af47cd6ea5fe53ed8cc13
Bug 847841 adding more logging when tests are done

https://github.com/mozilla/addon-sdk/commit/3714c1eeec0c99ff0cc1102624b75fe2464931c5
Merge pull request #1982 from erikvold/847841

Bug 847841 adding more logging when tests are done r=mossop
https://bugzilla.mozilla.org/show_bug.cgi?id=1399562
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 months ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.