After purging session history, web nav events aren't properly reset

VERIFIED WONTFIX

Status

()

Core
Embedding: APIs
VERIFIED WONTFIX
17 years ago
17 years ago

People

(Reporter: David Epstein, Assigned: Radha on family leave (not reading bugmail))

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
1. Make sure that session history listener has been added in the test framework.
In mfcEmbed, I added:
nsWeakPtr weakling(
        dont_AddRef(NS_GetWeakReference(NS_STATIC_CAST(nsISHistoryListener*,
mBrowserImpl))));
	rv = qaWebBrowser->AddWebBrowserListener(weakling, NS_GET_IID(nsISHistoryListener));

2. Enter at least one url to create a session history.
3. Purge session history. In mfcEmbed:
  nsCOMPtr<nsISHistory> theSessionHistory;
  mWebNav->GetSessionHistory( getter_AddRefs(theSessionHistory));
  rv = theSessionHistory->GetCount(&numEntries);
  rv = theSessionHistory->PurgeHistory(numEntries);
4. Notice that the back and forward buttons are disabled. That's fine at this
point. Now, enter another url.
Result: The session history events are disabled (forward, back, reload, etc.)
Expected: Since we've entered a url, they should be enabled.
Note: They get enabled after entering the Second url.
I will look in to this.I think I have a clue on what the problem is.
Assignee: adamlock → radha
(Reporter)

Comment 2

17 years ago
changing qa contact to depstein
QA Contact: mdunn → depstein
Myself and depstein talked about it. THis is due to the way pages are added to 
SH. Fixing this will bring up another bug. I think it is not a serious flaw in 
the way PurgeHistory works. 
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 4

17 years ago
verifying.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.