Closed Bug 848070 Opened 8 years ago Closed 8 years ago

Crash org.mozilla.gecko.TabsPanel.<init>(TabsPanel.java:84)

Categories

(Firefox for Android Graveyard :: General, defect)

22 Branch
ARM
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 22

People

(Reporter: daniel.nr01, Assigned: lucasr)

References

Details

(Keywords: crash, Whiteboard: [native-crash])

Attachments

(3 files)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20130303 Firefox/22.0
Build ID: 20130303030835

Steps to reproduce:

Some week ago Nightly stopped working on my Xperia Neo. When I launch the app the screen goes white and stays that way. I'm using a Nightly from 2013-03-04 and I'm running Android 4.0.4.
Version: unspecified → Firefox 22
OS: Windows 7 → Android
Hardware: x86_64 → ARM
Can you capture and attach to this bug some logcat output capturing the sequence of events when you launch Firefox?
I recorded a log with the aLogcat app. Please tell me if it's not sufficient and I will gladly provide more information.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: crash
Summary: Nightly mobile does not start → Crash org.mozilla.gecko.TabsPanel.<init>(TabsPanel.java:84)
E/GeckoViewsFactory(  334): Unable to instantiate view org.mozilla.gecko.TabsTray
E/GeckoViewsFactory(  334): java.lang.reflect.InvocationTargetException
E/GeckoViewsFactory(  334): 	at java.lang.reflect.Constructor.constructNative(Native Method)
E/GeckoViewsFactory(  334): 	at java.lang.reflect.Constructor.newInstance(Constructor.java:417)
E/GeckoViewsFactory(  334): 	at org.mozilla.gecko.GeckoViewsFactory.onCreateView(GeckoViewsFactory.java:105)
E/GeckoViewsFactory(  334): 	at android.view.LayoutInflater.createViewFromTag(LayoutInflater.java:669)
Assignee: nobody → lucasr.at.mozilla
Duplicate of this bug: 844899
We should get a fix in so we dont lose more Nightly testers
Whiteboard: [native-crash]
I have a tentative fix for this bug. Could anyone with an affected xperia device try this test build and let me know if it crashes on startup?

  https://dl.dropbox.com/u/1187037/xperia-fix.apk
Daniel, would you be able to test out the above package? It's an unbranded version of Fennec that contains a tentative fix.
Flags: needinfo?(daniel.nr01)
Sorry, it didn't work :/ The symptoms are the same as before. I've attached a new logcat if it is of any help.
Flags: needinfo?(daniel.nr01)
Hey Daniel, could you try this one and let me know if it works?

  https://dl.dropbox.com/u/1187037/xperia-fix-2.apk
Sorry, this is the correct apk:

  https://dl.dropbox.com/u/1187037/xperia-fix-3.apk
Nightly: https://appthwack.com/public/ieDbm92rla (Failures)
xperia-fix-3: https://appthwack.com/public/FScl0s72eu (Green)

The above build seems to do the trick.
It seems we can't rely on having stable ids on Android's built-in style attributes. It seems that on some xperia phones some attribute ids are higher than the size of style attributes declared in TwoWayView, causing that ArrayOutOfBounds exception.

We have to explicitly declare all View style attributes in TwoWayView to ensure this is never going to happen.

Aaron just verified that the patch works on the affected devices.
Attachment #725403 - Flags: review?(mark.finkle)
Attachment #725403 - Flags: review?(mark.finkle) → review+
(In reply to Lucas Rocha (:lucasr) from comment #10)
> Sorry, this is the correct apk:
> 
>   https://dl.dropbox.com/u/1187037/xperia-fix-3.apk

It does work indeed. Great job!
https://hg.mozilla.org/mozilla-central/rev/ac609be0e139
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 22
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.