Closed Bug 848113 Opened 12 years ago Closed 12 years ago

Stuck on the last screen of purchase since GET /_/js/buynow-main.js is a 404

Categories

(Marketplace Graveyard :: Payments/Refunds, defect, P1)

defect

Tracking

(Not tracked)

RESOLVED FIXED
2013-03-14

People

(Reporter: krupa.mozbugs, Assigned: keir)

References

Details

(Keywords: regression)

Tester is on wifi

steps to reproduce:
1. Start the purchase flow for a paid app on your unagi phone
2. Sign in with Identity
3. Enter PIN
4. Confirm phone number
5. In the Confirm your purchase screen, click the "Buy" screen.

expected behavior:
Purchase is successfully completed

observed behavior:
User is stuck in the Confirm your purchase screen because GET /_/js/buynow-main.js is a 404

http request [
GET /_/js/buynow-main.js HTTP/1.1
 Host: mozilla.test.bango.org
 User-Agent: Mozilla/5.0 (Mobile; rv:18.0) Gecko/18.0 Firefox/18.0
Accept: */*
 Accept-Language: en-US,en;q=0.5
 Accept-Encoding: gzip, deflate
Referer: http://mozilla.test.bango.org/payment/buynow/
Cookie: ASP.NET_SessionId=fei4pu2pj1i0u1cvz4plidzo; bgo_id=userId=HUzzNZEig2zN2PnOw9FClQ==&network=g1aeKbznwCdgCNIRQe/Lrw==&region=eJuOs2Pg9cSvc/oQt0jVWg==
Connection: keep-alive
I/PRLog   (  108): 2013-03-05 19:16:40.553614 UTC - 1074955512[4041c080]: ]
I/PRLog   (  108): 2013-03-05 19:16:40.720942 UTC - 7872464[404ebd00]: nsHttpTransaction::HandleContentStart [this=47455620]
Duration:        0.170 47455620       (mozilla.test.bango.org -> GET /_/js/buynow-main.js)
http response [
HTTP/1.1 404 Not Found
Content-Length: 1635
Content-Type: text/html
x-powered-by: ASP.NET
Date: Tue, 05 Mar 2013 19:16:42 GMT
I/PRLog   (  108): 2013-03-05 19:16:40.721217 UTC - 7872464[404ebd00]:
Keywords: regression
Krupa, can you tell us the network, phone number and has the user made any purchases before on the device either on mobile data or wifi
T-mobile and I'm on wifi. I'll email the phone number since i'm not comfortable listing a colleague's contact info in such a public place.
Priority: -- → P1
Resolved.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.