tab and window module related test failures on Fennec due to pb updates

RESOLVED FIXED in 1.15

Status

Add-on SDK
General
P1
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: erikvold, Assigned: erikvold)

Tracking

unspecified
1.15

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

tests/test-private-browsing.testIsPrivateOnTab: failure, exception
tests/test-private-browsing.testWindowDefaults: exception
tests/test-tabs-common.testPrivateAreNotListed: failure
Assignee: nobody → evold
Target Milestone: --- → 1.14
Convince me this is a 1.14 bug.
Flags: needinfo?(evold)
I think I broke a module used only on Fennec in a private browsing bug that would has landed on stabilization, so there would be a regression.  I think the tests themselves may be fine.
Flags: needinfo?(evold)
What's the impact of the regression then, do we completely fail on fennec?
Flags: needinfo?(evold)
ok it looks like only window.isPrivate was broken on Fennec, and the ptpb tests were also broken.  So it's not huge, but I've got a patch now.
Flags: needinfo?(evold)
Created attachment 722490 [details]
Pointer to Github pull request: https://github.com/mozilla/addon-sdk/pull/843

Pointer to Github pull-request
Attachment #722490 - Flags: review?(poirot.alex)

Updated

5 years ago
Priority: -- → P1
Target Milestone: 1.14 → 1.15
Attachment #722490 - Flags: review?(poirot.alex) → review+

Comment 6

5 years ago
Commits pushed to master at https://github.com/mozilla/addon-sdk

https://github.com/mozilla/addon-sdk/commit/c36e2779d74ccfed146ae7ddd0d920e2c774eeb4
Bug 848180: fixing ptpb tests on Fennec and a minor regression where window.isPrivate would fail on Fennec

https://github.com/mozilla/addon-sdk/commit/214b6737249feee783e05bb060160fde60db833c
Merge pull request #843 from erikvold/848180

Fix Bug 848180: fixing ptpb tests and window.isPrivate on Fennec r=@ochameau

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Blocks: 853331

Comment 7

5 years ago
Commit pushed to stabilization at https://github.com/mozilla/addon-sdk

https://github.com/mozilla/addon-sdk/commit/d8cdc07ea821aa8fecfd8ef9320ae25839b8336d
Merge pull request #843 from erikvold/848180

Fix Bug 848180: fixing ptpb tests and window.isPrivate on Fennec r=@ochameau(cherry picked from commit 214b6737249feee783e05bb060160fde60db833c)
You need to log in before you can comment on or make changes to this bug.