Removing occurrence corrupts server data

RESOLVED INVALID

Status

RESOLVED INVALID
6 years ago
5 years ago

People

(Reporter: a1291762, Unassigned)

Tracking

Lightning 1.9

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.22 (KHTML, like Gecko) Chrome/25.0.1364.97 Safari/537.22

Steps to reproduce:

Removed an occurrence from a repeating event on a Google Calendar.


Actual results:

The occurrence was not removed from the Android phone the calendar synchronizes to.


Expected results:

The occurrence should have been removed from the Android phone.


I know... this doesn't sound like a mozilla bug but while trying to come up with a concrete set of steps that reproduce the bug, I found that while I could get the problem to show up when using the Provided for GData, I could not get the problem to show up when using CalDAV so maybe the information sent to Google Calendar is somehow wrong?

I also raised this against Android (since the occurrence is removed from Google Calendar but not the Android phone it syncs with). https://code.google.com/p/android/issues/detail?id=52832

Comment 1

6 years ago
Hi...

What was the resultin the Google web interface? I would say that if the desired result was achieved there, the problem lies either in Google's handling of the event modification or (as you have also surmised) in Android's handling of the update. It's always important when tracking these things down between multiple devices that we see what the common factor (e.g., Google) is doing.

Also, anything of interest in the debug log (GData debug log, that is)?

Lewis
(Reporter)

Comment 2

5 years ago
Since CalDav had its own problems (mostly really poor performance on my large calendar) I switched back to the GData provider and... it seems to be behaving. I've seen odd issues but they were all between Google Calendar and Android so I'm going to close this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.