Bugzilla query page loads 4x slower than in Netscape 4.77

VERIFIED WORKSFORME

Status

()

Core
Layout
VERIFIED WORKSFORME
17 years ago
10 years ago

People

(Reporter: Diego Biurrun, Assigned: karnaze (gone))

Tracking

({perf})

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
I saved the bugzilla query page to a local file in order to be able to better
compare the values.

In 2001060713 and 2001060809 the bugzilla query page takes more than 6 seconds
to load, whereas Netscape 4.77 loads it in under 2 seconds. That is a huge
performance gap.
(Reporter)

Comment 1

17 years ago
Sorry, there's some info about my system missing from my bugreport:

K6-2-500 with 256MB RAM running Linux 2.4.5
Keywords: perf
Summary: Bugzilla query page vastly slower than in Netscape 4.77 → Bugzilla query page 4x slower than in Netscape 4.77
(Reporter)

Comment 2

17 years ago
I'm not sure if this has anything to do with it, but I see parts of the banner
(the dinosaur head) appear on various parts of the page while it gets rendered.
Netscape 4.77 does not do that.

Comment 3

17 years ago
I can see this too on win98 with 0.9.1
-> layout for initial triage
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All

Comment 4

17 years ago
lemme try zat again
Assignee: asa → karnaze
Component: Browser-General → Layout
QA Contact: doronr → petersen
(Reporter)

Comment 5

17 years ago
I compared a few other bugzilla result pages and mozilla is consistently faster
in loading pages that I save locally beforehand. I regularly see mozilla
rendering two dinos in the space where the severity field ends up and below the
add CC.

Comment 6

17 years ago
well there should be only one such bug open about this at any time, but i 
found two, bug 49539 and bug 50411.

*** This bug has been marked as a duplicate of 49539 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 7

17 years ago
Timeless, please review your duplication of this bug. This bug is about complex
forms like the bugzilla query page, bug 49539 talks about huge query _results_.
query.cgi is only 68k big. Mozilla does not hang or experience major memory
leaks and crash while rendering query.cgi, it is just goddarn slow.

Comment 8

17 years ago
sorry the reporter's last comments were indeed about that bug I picked, but he 
meant to focus on the query.cgi page, so that leaves bug 46298 and bug 19608.  
If qa thinks either is a good match that's fine, otherwise reopening. thanks 
for using bugzilla and contacting me on irc.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Summary: Bugzilla query page 4x slower than in Netscape 4.77 → Bugzilla query page loads 4x slower than in Netscape 4.77

Comment 9

17 years ago
*** Bug 87778 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Depends on: 63890
(Reporter)

Comment 10

17 years ago
linux, build 2001070209

Performance is much improved, no stray lizard heads are rendered on the page,
the forms have stopped dancing around the page. Still Netscape 4.77 is twice as
fast.
Keywords: 4xp

Comment 11

17 years ago
I am running Mozilla on Windows 95 on a Pentium 200 MMX with 64 MB of ram.
Mozilla renders _Most_ sites with speed comparable to Netscape 4.x on the same
machine, but the Bugzilla Query page is a notable exception. Whenever I load
http://bugzilla.mozilla.org/query.cgi in Mozilla, the page starts to render,
then ALL my open Mozilla Windows lock for about 8 to 10 seconds, then the page
finishes rendering.

You know how when you pick a program such as "Browser" or "Mailnews" or
whatever, and then it filters down the "component" "Version" and "Target
Milestone" Fields? Well, when I do that, Mozilla locks for about 20-30 seconds.
If I then go ahead and submit the query, and after browsing the results I return
to the query page with the back button, all my Mozilla windows lock up again for
about 30-40 seconds.

Could I be seeing the same symptom that this bug describes, just horribly
amplified by my slow machine? When you change the selected program using
Netscape 4.x, the "component" "Version" and "Target Milestone" are filtered down
very quickly without blocking the UI at all.

Comment 12

17 years ago
MozillaUser, you are seeing the symptoms of a number of bugs. The first
one has been checked into the Bugzilla tree today and should make it to
b.m.o. by this week or so, pending approval of 2.14+ by Myk. This is bug
96534; I rewrote the Javascript to make it much faster. You can see the
results of the changes by visiting
http://landfill.tequilarista.org/bz96534/ (note speed difference in
query.cgi and query4.cgi).

The other bug you are noticing is bug 97345, which jesup is working hard
to get in before 0.9.5. You can check out the patch and progress there
as well. If your report is accurate, we should either close this bug,
or depend it on the two. There are already perf trackers for Mozilla.

Comment 13

17 years ago
Marking WORKSFORME (this was a dupe of bug 46298 now that I think of it) with
the current bugzilla upgrade. Additional perf sould be obtained when bug 97345
lands.
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 14

17 years ago
I would say this is still slightly slower, but maybe 10-20%, nowhere near 4
times. ---> VERIFIED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.