The product component search field is not putting bugzilla.mozilla.org components before upstream Bugzilla components

RESOLVED FIXED

Status

()

bugzilla.mozilla.org
Extensions: ProdCompSearch
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: dkl, Assigned: glob)

Tracking

(Blocks: 1 bug)

Production
x86_64
Linux

Details

(Reporter)

Description

5 years ago
Seems like the client side javascript is re-sorting the data as it is being display maybe? The webservice code looks correct and has not changed but the client side code has been rewritten in YUI3 and therefore could be at fault.
(Reporter)

Updated

5 years ago
Blocks: 848218
(Assignee)

Comment 1

5 years ago
the problem was there were three prod_comp_search webservice methods, in the BMO, MyDashboard and ProdCompSearch extensions.

the javascript in ProdCompSearch was calling the method in MyDashboard, which was old and didn't have the fix for sorting bugzilla.mozilla.org first.

i've deleted prod_comp_search from BMO and MyDashboard, and updated the js to call ProdCompSearch's implementation.

Committing to: bzr+ssh://bjones%40mozilla.com@bzr.mozilla.org/bmo/4.2/
modified extensions/BMO/lib/WebService.pm
modified extensions/MyDashboard/lib/WebService.pm
modified extensions/ProdCompSearch/Extension.pm
modified extensions/ProdCompSearch/lib/WebService.pm
modified extensions/ProdCompSearch/web/js/prod_comp_search.js
Committed revision 8629.
Assignee: dkl → glob
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.