[Settings] Remove useless code

RESOLVED FIXED

Status

--
trivial
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: masashi.honma, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

6 years ago
On gaia/apps/settings/js/wallpaper.js#onPickSuccess 'a.result.url' is not defined at the moment.

Setting it to self.preview.src and 'wallpaper.image' should be done in reader.onload.

So I removed these lines.
(Reporter)

Comment 1

6 years ago
See PR #8486.
(Reporter)

Comment 2

6 years ago
Created attachment 722560 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/8486/files

Pointer to Github pull-request
(Reporter)

Updated

6 years ago
Attachment #722560 - Attachment mime type: text/plain → text/html
(Reporter)

Updated

6 years ago
Attachment #722560 - Flags: review?(dflanagan)
Comment on attachment 722560 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/8486/files

Thank you for this patch. Sorry it has taken me so long to review it.

This isn't just useless code, its a real bug, and we should land this patch. Github is reporting that it will not merge cleanly. I can't see why because it looks good to me. If you investigate and fix the pull request, just email me and I'll land it.
Attachment #722560 - Flags: review?(dflanagan) → review+
(Reporter)

Comment 4

6 years ago
Created attachment 725809 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/8486/files

Pointer to Github pull-request
(Reporter)

Updated

6 years ago
Attachment #725809 - Attachment is obsolete: true
Attachment #725809 - Attachment mime type: text/plain → text/html
(Reporter)

Comment 5

6 years ago
Created attachment 725812 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/8691

Pointer to Github pull-request
(Reporter)

Updated

6 years ago
Attachment #725812 - Attachment mime type: text/plain → text/html
Attachment #725812 - Flags: review?(dflanagan)
(Reporter)

Comment 6

6 years ago
I modified the patch. See PR 8691.
Comment on attachment 725812 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/8691

Looks good.
Attachment #725812 - Flags: review?(dflanagan) → review+

Updated

6 years ago
Attachment #722560 - Attachment is obsolete: true
Merged into master: https://github.com/mozilla-b2g/gaia/commit/d9a4ac0b9f88edc33c40aef65ea60239f9b4bb37
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.