bug summary tooltip now includes "---" for unresolved bugs

RESOLVED FIXED in Bugzilla 4.2

Status

()

Bugzilla
User Interface
--
minor
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Gavin, Assigned: Frédéric Buclin)

Tracking

Bugzilla 4.2
Bug Flags:
approval +
approval4.4 +
approval4.2 +

Details

Attachments

(1 attachment)

Potentially an upstream change, but I'm not sure that it's intentional.

Hovering over the bug link for an unresolved (like this one: bug 848218) shows "NEW --- - [summary]", which looks weird. I assume "---" is the string representation of the null resolution - it should just be omitted.
It is an upstream change. Bugzilla 4.0 did not replace an empty resolution value in the buglink title with '---' as it does now. I admit that it doesn't look ideal but I am not sure it is worth the customization we would need to do to make it look like the old way. We try to stay as close upstream as we can. I will move this bug to the upstream and we can discuss it further there.

dkl
Assignee: nobody → ui
No longer blocks: 848218
Component: General → User Interface
Product: bugzilla.mozilla.org → Bugzilla
QA Contact: default-qa
Version: Production → 4.2
(Assignee)

Comment 2

5 years ago
Created attachment 721932 [details] [diff] [review]
patch, v1

This is a regression due to bug 595410.
Assignee: ui → LpSolit
Status: NEW → ASSIGNED
Attachment #721932 - Flags: review?(dkl)
(Assignee)

Updated

5 years ago
Severity: normal → minor
OS: Mac OS X → All
Hardware: x86 → All
Target Milestone: --- → Bugzilla 4.2
(Assignee)

Updated

5 years ago
Depends on: 595410
Comment on attachment 721932 [details] [diff] [review]
patch, v1

Review of attachment 721932 [details] [diff] [review]:
-----------------------------------------------------------------

r=dkl
Attachment #721932 - Flags: review?(dkl) → review+

Updated

5 years ago
Flags: approval?
Flags: approval4.4?
Flags: approval4.2?
(Assignee)

Updated

5 years ago
Flags: approval?
Flags: approval4.4?
Flags: approval4.4+
Flags: approval4.2?
Flags: approval4.2+
Flags: approval+
(Assignee)

Comment 4

5 years ago
Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/trunk/
modified template/en/default/bug/link.html.tmpl
Committed revision 8588.

Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/4.4/
modified template/en/default/bug/link.html.tmpl
Committed revision 8528.

Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/4.2/
modified template/en/default/bug/link.html.tmpl
Committed revision 8195.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.