Closed Bug 84826 Opened 19 years ago Closed 19 years ago

Simultaneous downloads lock up on the mac

Categories

(NSPR :: NSPR, defect)

PowerPC
Mac System 9.x
defect
Not set

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 85514

People

(Reporter: tever, Assigned: sfraser_bugs)

References

()

Details

Overview Description:  Downloading two or more files at the same time causes the 
transfer to lockup.   The progress bar in the 'Saving File' dialog stops and you 
need to hit 'cancel' to remove the window.  We might have had this before but if 
we did I can't find it.  Mac only.

Steps to Reproduce:
1.)  Go to ftp site - I used internal sweetlou but any should work
2.)  start downloading by doubleclicking file
3.)  immediatly start a second and third download
4.)  try this a few times and eventually you will lock up

Works on winNT and Linux for me.
build id is 20010607 (branch)  
tever, can you try the same thing using large http files?
Hey Doug, do you mean downloading a large file using http?  And how large of a 
file do you want me to test?  These files were in the 10 - 20 Meg range.
tom, try to reproduce this bug in exactly the same fashion, but use the http 
protocol instead of ftp.  If HTTP has the same problem as ftp, try reproducing 
on windows or linux.
Hardware: PC → Macintosh
this is a dup of a nspr bug, or so I am told.  Gordon, care to take a look?
Assignee: dougt → gordon
This is very likely the same as bug 85514.
over to Simon. Thanks.
Assignee: gordon → sfraser
0.9.2
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.2
After applying the patch in bug 85514, I was able to do 2 simultaneous downloads.


*** This bug has been marked as a duplicate of 85514 ***
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
verified dup
Status: RESOLVED → VERIFIED
Component: Networking: FTP → NSPR
Product: Browser → NSPR
Target Milestone: mozilla0.9.2 → ---
You need to log in before you can comment on or make changes to this bug.