Last Comment Bug 848292 - Icons for special IMAP folder (Inbox, trash, ...) are not shown when folder is shared
: Icons for special IMAP folder (Inbox, trash, ...) are not shown when folder ...
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Theme (show other bugs)
: Trunk
: All All
: -- trivial with 1 vote (vote)
: Thunderbird 22.0
Assigned To: Tony Mechelynck [:tonymec]
:
Mentors:
Depends on:
Blocks: 160644
  Show dependency treegraph
 
Reported: 2013-03-06 03:57 PST by Tony Mechelynck [:tonymec]
Modified: 2013-03-09 16:02 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
patch v0 (rules commented-out) (4.38 KB, patch)
2013-03-06 04:47 PST, Tony Mechelynck [:tonymec]
richard.marti: review+
Details | Diff | Splinter Review
patch v0.1 (r+=Paenglab) addressing comment #3 (4.35 KB, patch)
2013-03-07 19:03 PST, Tony Mechelynck [:tonymec]
antoine.mechelynck: review+
Details | Diff | Splinter Review

Description Tony Mechelynck [:tonymec] 2013-03-06 03:57:12 PST
+++ This bug was initially created as a clone of Bug #840003 +++

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:18.0) Gecko/20100101 Firefox/18.0 SeaMonkey/2.15.2
Build ID: 20130203000651

Steps to reproduce:

Setup imap account.


Actual results:

Special folder (Inbox trash, Junk, ...)  have the generic shared folder icon when these folders are shared (they can't be unshared). See attachement.


Expected results:

Special folders should have special icons.
Comment 1 Tony Mechelynck [:tonymec] 2013-03-06 04:47:55 PST
Created attachment 721658 [details] [diff] [review]
patch v0 (rules commented-out)

On closer inspection of the source, Thunderbird should not suffer from the bug because the shared folder rules are commented-out. They are at the wrong place though.

This first version of the patch moves them at a better position (earlier in the bug, i.e., at a lesser priority) and adds a placeholder for gnomestripe which did not even have a commented-out rule.
Comment 2 Tony Mechelynck [:tonymec] 2013-03-06 08:23:35 PST
removing dependency because at this stage both bugs can evolve in parallel
Comment 3 Richard Marti (:Paenglab) 2013-03-06 09:39:46 PST
Comment on attachment 721658 [details] [diff] [review]
patch v0 (rules commented-out)

Review of attachment 721658 [details] [diff] [review]:
-----------------------------------------------------------------

Thank you Tony for the patch. If we use it in the future then it's correctly before the new mail rule.

r+ with the comment addressed.

::: mail/themes/gnomestripe/mail/folderPane.css
@@ +22,5 @@
> +/* ..... Shared folders ..... */
> +treechildren::-moz-tree-image(folderNameCol, imapShared-true) {
> +  /* no rule yet in this theme */
> +}
> +

Please can you comment out the whole rule like in the other themes? You can also remove the line /* no rule yet in this theme */ and let it epty.
Comment 4 Tony Mechelynck [:tonymec] 2013-03-07 19:03:45 PST
Created attachment 722610 [details] [diff] [review]
patch v0.1 (r+=Paenglab) addressing comment #3
Comment 5 Tony Mechelynck [:tonymec] 2013-03-07 19:20:27 PST
I haven't checked that the image-part referenced by coordinates in the commented-out rule for qute is the right one, or that the separate "folder-share.png" for pinstripe exists. If they aren't as should be, or if different icons are desired for shared folders, then this bug ought to block the Thunderbird equivalent (if there is one, or when there will be one) of SeaMonkey bug 132927.

Similarly if any "shared" icon at all is desired for gnomestripe.

Oh, and BTW, please excuse my naivety: if pinstripe is for Mac, and gnomestripe and qute are for Linux GTK2 and Qt respectively, where is the theme for Windows?
Comment 6 Tony Mechelynck [:tonymec] 2013-03-07 20:44:58 PST
I've just posted a message on mozilla.dev.apps.thunderbird (and mozilla.dev.apps.seamonkey for bug 840003) in the hope that the authors of existing third-party themes will see it, and, if necessary, take the required action.
Comment 7 neil@parkwaycc.co.uk 2013-03-08 01:10:29 PST
(In reply to Tony Mechelynck from comment #5)
> Oh, and BTW, please excuse my naivety: if pinstripe is for Mac, and
> gnomestripe and qute are for Linux GTK2 and Qt respectively, where is the
> theme for Windows?

Both GTK2 and Qt use gnomestripe; Windows uses qute. (Although I guess they should be renamed in light of the toolkit renaming...)
Comment 8 Ryan VanderMeulen [:RyanVM] 2013-03-09 16:02:47 PST
https://hg.mozilla.org/comm-central/rev/68a3857fbcab

Note You need to log in before you can comment on or make changes to this bug.