[email] fix secret debug menu's fancy structured debug logging saving to DeviceStorage

RESOLVED FIXED

Status

Firefox OS
Gaia::E-Mail
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: asuth, Assigned: asuth)

Tracking

unspecified
x86_64
Linux

Firefox Tracking Flags

(b2g18 fixed, b2g18-v1.0.1 fixed)

Details

(Assignee)

Description

5 years ago
Current sync issues when dog-fooding need our structured logging capabilities.  We've been getting by on console.log, but we're going to get rid of that for performance reasons.  At some point we regressed so that we fail when writing our log out to DeviceStorage.  I shall fix it on this bug.
(Assignee)

Comment 1

5 years ago
The regression was that ".rm" was removed from the list of legal file extensions.  I guess I had been too clever about choosing an extension that was unlikely to be used by anything real.

landed on gaia-email-libs-and-more/master:
https://github.com/mozilla-b2g/gaia-email-libs-and-more/pull/140

landed on gaia-master:
https://github.com/mozilla-b2g/gaia/pull/8495

It looks super duper debugging mode may be experiencing a problem where the logger is not getting properly rooted and as a result we are missing important IMAP protocol log output.
(Assignee)

Comment 2

5 years ago
The super verbose mode was unhappy because of our lazy module loading stuff.  Now resolved:

landed on gaia-email-libs-and-more/master:
https://github.com/mozilla-b2g/gaia-email-libs-and-more/pull/141

landed on gaia/master:
https://github.com/mozilla-b2g/gaia/pull/8498
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
both commits were landed in v1.0.1 as part of Bug 851124 big uplift.
Will land (again) in v1-train tomorrow at the latest too.
status-b2g18-v1.0.1: --- → fixed
Landed in v1-train as part of Bug 851124 big uplift.
status-b2g18: --- → fixed
You need to log in before you can comment on or make changes to this bug.