Reduce browser.slowStartup.timeThreshold to a more aggressive value

VERIFIED FIXED in Firefox 31

Status

()

VERIFIED FIXED
6 years ago
a year ago

People

(Reporter: Dolske, Assigned: dao)

Tracking

unspecified
Firefox 32
Points:
---
Dependency tree / graph
Bug Flags:
firefox-backlog +

Firefox Tracking Flags

(firefox31 fixed, firefox32 fixed)

Details

(Whiteboard: p=1 s=it-32c-31a-30b.3 [qa-])

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Currently browser.slowStartup.timeThreshold is 60 seconds, which was deliberately conservative. We should look at the relevant data and feedback, and see what would be an acceptable next step as a lower value. My gut tells me 30 seconds would be a fine next step, but that might also be indigestion. Maybe an even lower value; a 30 second startup still feels really terrible.
Do we have telemetry data around average startups?

Comment 2

6 years ago
Firefox 21 is reporting main, first paint, and session restored times for a majority of our users through Firefox Health Report. I reckon you could ask Metrics for data so this could be a data-driven decision. This may require waiting for FHR to collect a sufficient sample size from the Beta and/or Release channels. Presumably a change to this preference could be uplifted to Beta if you are worried about making this feature more useful sooner.
From Wed, Feb 6th #perf scrollback (yikes)...
12:45 PM <taras> jaws: btw, i think the 1min delay is a good one to ship this the first time
12:45 PM <taras> i would be reluctant to make it any lower
12:45 PM <taras> since some hw reliably has 45s startups

It's also worth noting that bug 836010 landed in Fx21, so if we change it now then the new value will ride a different train (which would be good).

Taras, what do you think about reducing this value for Fx22?
Flags: needinfo?(taras.mozilla)

Comment 4

6 years ago
Do we have telemetry data that shows us how often users act-on/ignore this infobar?
Flags: needinfo?(taras.mozilla) → needinfo?(jAwS)
(In reply to Taras Glek (:taras) from comment #4)
> Do we have telemetry data that shows us how often users act-on/ignore this
> infobar?

We don't have any telemetry to track if users dismiss the notification or click on the button, but SUMO should be able to track the visit rate of the linked article.
Flags: needinfo?(jAwS)
(Reporter)

Comment 6

6 years ago
(In reply to Jared Wein [:jaws] from comment #3)

> 12:45 PM <taras> i would be reluctant to make it any lower
> 12:45 PM <taras> since some hw reliably has 45s startups

Are you talking ancient low-end HW where that would be expected and normal (for other browsers too)? Or something different?

I suppose we could tune the threshold based on CPU+mem+HD info. But I'm hesitant to make this too complex (although I'm also unclear what the eventual FHR plans are here), and I'd be surprised if we have any existing data that correlates such factors.
Flags: needinfo?(taras.mozilla)

Comment 7

6 years ago
(In reply to Jared Wein [:jaws] from comment #5)
> (In reply to Taras Glek (:taras) from comment #4)
> > Do we have telemetry data that shows us how often users act-on/ignore this
> > infobar?
> 
> We don't have any telemetry to track if users dismiss the notification or
> click on the button, but SUMO should be able to track the visit rate of the
> linked article.

We should add some. SUMO can't tell us what proportion of users ignore an extra infobar

Justin, $300 laptop hardware with new windows installs. Combination of anti-virus crapware + windows indexing taking a few weeks to complete without regard to io priority + world's crappiest HDs is lethal.
Flags: needinfo?(taras.mozilla)
(Assignee)

Comment 8

6 years ago
(In reply to Taras Glek (:taras) from comment #7)
> Justin, $300 laptop hardware with new windows installs. Combination of
> anti-virus crapware + windows indexing taking a few weeks to complete
> without regard to io priority + world's crappiest HDs is lethal.

We actually try to help these users...

https://support.mozilla.org/en-US/kb/firefox-takes-long-time-start-up#w_check-your-antivirus-software

https://support.mozilla.org/en-US/kb/firefox-takes-long-time-start-up#w_optimize-windows
(Assignee)

Updated

4 years ago
Flags: firefox-backlog+
Whiteboard: p=1
(Assignee)

Comment 9

4 years ago
If I read http://telemetry.mozilla.org/#release/29/SIMPLE_MEASURES_FIRSTPAINT correctly, 6% of the first paints take 30 seconds or longer. 6% seems like a lot, so I think we should be more conservative with reducing the threshold. Of course this doesn't need to be the last time we reduce it.
(Assignee)

Comment 10

4 years ago
Created attachment 8426878 [details] [diff] [review]
45 seconds

My gut feeling says 50 or 45 seconds would be reasonable next steps. How about we try 50 seconds in Firefox 31 and 45 seconds in Firefox 32? Maybe another 5 second reduction after that, etc.
Assignee: nobody → dao
Status: NEW → ASSIGNED
Attachment #8426878 - Flags: review?(dolske)
(Assignee)

Comment 11

4 years ago
Created attachment 8426879 [details] [diff] [review]
50 seconds for Aurora uplift
Attachment #8426879 - Flags: review?(dolske)
(Reporter)

Updated

4 years ago
Attachment #8426878 - Flags: review?(dolske) → review+
(Reporter)

Updated

4 years ago
Attachment #8426879 - Flags: review?(dolske) → review+
(Reporter)

Comment 12

4 years ago
(In reply to Dão Gottwald [:dao] from comment #10)

> My gut feeling says 50 or 45 seconds would be reasonable next steps. How
> about we try 50 seconds in Firefox 31 and 45 seconds in Firefox 32? Maybe
> another 5 second reduction after that, etc.

WFM. It would be nice if the Telemetry dashboard gave us the ability to see a finer breakdown for reports over > 30 seconds (or is that just 1 big bucket as reported by the client?). Also there appears to be some bogus data reported over the last month, as the media/mean jumped enormously and made the pushed the other data on the evolution graph to the bottom. :(
(Assignee)

Comment 13

4 years ago
Marco, please add this to the current iteration?

https://hg.mozilla.org/integration/fx-team/rev/832f1617782b
Flags: needinfo?(mmucci)
(Assignee)

Comment 14

4 years ago
Comment on attachment 8426879 [details] [diff] [review]
50 seconds for Aurora uplift

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 836010 (feature, not a regression)

User impact if declined: no slow-startup notification for users experiencing startups that take between 50 and 60 seconds on average

Testing completed (on m-c, etc.): patch setting the threshold to 45 seconds is in the process of landing

Risk to taking this patch (and alternatives if risky): low

String or IDL/UUID changes made by this patch: none
Attachment #8426879 - Flags: approval-mozilla-aurora?
Added to Iteration 32.2
Flags: needinfo?(mmucci)
Whiteboard: p=1 → p=1 s=it-32c-31a-30b.2 [qa?]
https://hg.mozilla.org/mozilla-central/rev/832f1617782b
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 32
Hi Juan, can you review the bug to determine if further verification is required.
Flags: needinfo?(jbecerra)
(Assignee)

Updated

4 years ago
Blocks: 1015619
status-firefox31: --- → affected
status-firefox32: --- → fixed
Attachment #8426879 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Updated

4 years ago
Whiteboard: p=1 s=it-32c-31a-30b.2 [qa?] → p=1 s=it-32c-31a-30b.3 [qa?]

Updated

4 years ago
Flags: needinfo?(jbecerra)
Whiteboard: p=1 s=it-32c-31a-30b.3 [qa?] → p=1 s=it-32c-31a-30b.3 [qa-]

Updated

4 years ago
Status: RESOLVED → VERIFIED
(Assignee)

Updated

a year ago
Blocks: 1379245
(Assignee)

Updated

a year ago
Blocks: 1389590
You need to log in before you can comment on or make changes to this bug.