Add a Favicon Underlay in Browser

VERIFIED FIXED

Status

VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: pabratowski, Assigned: sjochimek)

Tracking

unspecified
All
Other

Firefox Tracking Flags

(b2g18+ fixed)

Details

(Whiteboard: visual design, yedo, uxbranch, landed in uxbranch)

Attachments

(4 attachments)

(Reporter)

Description

6 years ago
Created attachment 721863 [details]
Layout Guide

Please add a favicon underlay when displaying the favicons in lists.
Underlay and visual guide attached with this bug.
(Reporter)

Comment 1

6 years ago
Created attachment 721864 [details]
Underlay Graphic
(Assignee)

Comment 2

6 years ago
Created attachment 722784 [details]
Patch
Attachment #722784 - Flags: feedback?
(Assignee)

Updated

6 years ago
Attachment #722784 - Flags: feedback? → feedback?(pabratowski)
(Assignee)

Comment 3

6 years ago
Created attachment 723944 [details]
After patch screenshot
(Reporter)

Comment 4

6 years ago
This looks great! Thank you Sam.

Updated

6 years ago
blocking-b2g: --- → leo?
Whiteboard: visual design, YEDO → visual design, yedo
(Assignee)

Updated

6 years ago
Attachment #722784 - Flags: feedback?(pabratowski) → review?(bfrancis)

Updated

6 years ago
blocking-b2g: leo? → ---
tracking-b2g18: --- → ?
Mass edit to set tracking-b2g18+ for these UX bugs that were called out for v1.1
tracking-b2g18: ? → +
Ben, can you review? We're hoping to get this reviewed by end of week so it can make it into v1.1.  Thanks!
Flags: needinfo?(bfrancis)
Comment on attachment 722784 [details]
Patch

Thanks for the patch and sorry for the long review time, I reviewed the patch on Github and I just have a couple of nits. If you remove the console.log line I think we're good :)

Where's the pull request?
Attachment #722784 - Flags: review?(bfrancis) → review+
Flags: needinfo?(bfrancis)

Updated

6 years ago
status-b2g18: --- → affected
(Assignee)

Comment 8

6 years ago
Oops here is the PR https://github.com/mozilla-b2g/gaia/pull/8674
Flags: needinfo?
(Assignee)

Comment 9

6 years ago
thanks Ben.

Landed in master: https://github.com/mozilla-b2g/gaia/commit/07706f330c0f556f21e63841dbbaa6713cbc9666
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Flags: needinfo?
Resolution: --- → FIXED

Updated

6 years ago
Whiteboard: visual design, yedo → visual design, yedo, uxbranch, landed in uxbranch
Verified in master.  uplift +1!

Master build : 2013-04-05-03-05-43
name="mozilla-central" revision="55f9e3e3dae7"  
name="integration/gaia-central" revision="2005e026bdae"
"gecko.git" revision="66b64f47a4eac1bd4f5ea6748b42ddf732297550"
"gaia.git" revision="15468abcba0dd2549f0c102df887a5c049b9c641"
Unagi
Status: RESOLVED → VERIFIED
Comment on attachment 722784 [details]
Patch

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: This increases the UX as it may be favicon with colors that will not have enough contrast with the background
Testing completed: 
Risk to taking this patch (and alternatives if risky): Low risk, just adding a new background to each item.
String or UUID changes made by this patch:
Attachment #722784 - Flags: approval-gaia-v1?

Updated

6 years ago
Attachment #722784 - Flags: approval-gaia-v1? → approval-gaia-v1+
I was not able to uplift this bug to v1-train.  If this bug has dependencies which are not marked in this bug, please comment on this bug.  If this bug depends on patches that aren't approved for v1-train, we need to re-evaluate the approval.  Otherwise, if this is just a merge conflict, you might be able to resolve it with:

  git checkout v1-train
  git cherry-pick -x -m1 07706f330c0f556f21e63841dbbaa6713cbc9666
  <RESOLVE MERGE CONFLICTS>
  git commit
Sam/Pavel, another conflict issue with uplift, can one of you take a look? Thanks!
Flags: needinfo?(sjochimek)
(Assignee)

Comment 14

6 years ago
v1-train: e3a79c545013846a6c5678c9c551811d47706870
status-b2g18: affected → fixed
Flags: needinfo?(sjochimek)
You need to log in before you can comment on or make changes to this bug.