Remove UA override for stackoverflow.com

RESOLVED FIXED

Status

Firefox OS
Gaia
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: jsmith, Assigned: lmandel)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g18 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

5 years ago
http://meta.stackoverflow.com/a/170294/166787 indicates this is fixed now. Let's remove the UA override.
(Reporter)

Updated

5 years ago
Depends on: 828408
Assignee: nobody → lmandel
Created attachment 721887 [details] [diff] [review]
Remove UA override for stackoverflow.com
Attachment #721887 - Flags: review?(fabrice)
Comment on attachment 721887 [details] [diff] [review]
Remove UA override for stackoverflow.com

Review of attachment 721887 [details] [diff] [review]:
-----------------------------------------------------------------

::: build/ua-override-prefs.js
@@ -51,5 @@
>  pref("general.useragent.override.scribd.com", "\(Mobile#(Android; Mobile"); // bug 827668
>  pref("general.useragent.override.elpais.com.co", "Mozilla/5.0 (Linux; Android 4.0.4; Galaxy Nexus Build/IMM76B) AppleWebKit/535.19 (KHTML, like Gecko) Chrome/18.0.1025.133 Mobile Safari/535.19"); // bug 827670
>  pref("general.useragent.override.olx.com.co", "\(Mobile#(Android; Mobile"); // bug 827672
>  pref("general.useragent.override.avianca.com", "\(Mobile#(Android; Mobile"); // bug 827674
> -pref("general.useragent.override.dropbox.com", "\(Mobile#(Android; Mobile"); // bug 827676

left over from a previous patch ;)
Attachment #721887 - Flags: review?(fabrice) → review+
Created attachment 721896 [details] [diff] [review]
Remove UA override for stackoverflow.com

Good catch. Here's a clean patch. Carrying the r+ forward
Attachment #721887 - Attachment is obsolete: true
Attachment #721896 - Flags: review+
Keywords: checkin-needed
master: 2e5046572756ebda8907b325a49c867f70eab7ee
Keywords: checkin-needed
Comment on attachment 721896 [details] [diff] [review]
Remove UA override for stackoverflow.com

[Approval Request Comment]
Bug caused by (feature/regressing bug #): N/A
User impact if declined: There should be no user visible issue. Users *may* see Android promotions due to the Fennec UA currently in use.
Testing completed: Tested on Unagi device.
Risk to taking this patch (and alternatives if risky): Very low. This patch removes one UA override patch.
String or UUID changes made by this patch: none.
Attachment #721896 - Flags: approval-mozilla-b2g18?
Given comment 4, looks like this should be resolved.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
Attachment #721896 - Flags: approval-mozilla-b2g18? → approval-gaia-v1+
Uplifted commit 2e5046572756ebda8907b325a49c867f70eab7ee as:
v1-train: 30f5a626cb10242fbf2c99bfb9ec49d81617bce4
status-b2g18: --- → fixed
You need to log in before you can comment on or make changes to this bug.