Make eagerlyTraceWeakMaps an enum

RESOLVED FIXED in mozilla22

Status

()

Core
JavaScript Engine
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: terrence, Assigned: terrence)

Tracking

Trunk
mozilla22
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Created attachment 721951 [details] [diff] [review]
v0

We will need an extra type of eagerlyTraceWeakMaps for GGC. I thought this was nice enough and orthogonal enough to split out into a separate patch.
Attachment #721951 - Flags: review?(wmccloskey)
Attachment #721951 - Flags: review?(wmccloskey) → review+
(Assignee)

Comment 1

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/1ccebe00cd2c
https://hg.mozilla.org/mozilla-central/rev/1ccebe00cd2c
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla22
(Assignee)

Updated

5 years ago
Duplicate of this bug: 772229
You need to log in before you can comment on or make changes to this bug.