Frames are not handled properly on complex sites

CLOSED WORKSFORME

Status

()

Core
Layout: HTML Frames
--
major
CLOSED WORKSFORME
17 years ago
17 years ago

People

(Reporter: G. Todd, Assigned: Eric Pollmann)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.12-20 i686; en-US; rv:0.9.1)
Gecko/20010607
BuildID:    2001060722

http://infobase6.ic.gc.ca/~smartpub/ at this URL (and similar sites) frames are
not rendered properly. Instead of the frame source appearing the refering page
for the link is rendered in the frames. The frame widths and positions are
correct however only the page content is wrong.

Reproducible: Always
Steps to Reproduce:
1. Go to an O'Reilly web board site such as:
2. http://infobase6.ic.gc.ca/~smartpub/
3.  Login (use guest here) and watch framse not work

Actual Results:  Frames become confused and lauch the same page in 3 separate
frames instead of 3 separate frames

Expected Results:  3 separate frames should appear in the browser

Works fine in Netscape 4.7 (and konqueror)

Comment 1

17 years ago
WFM on a linux cvs build from 6/22.  I'm 99% sure this was caused by bug 83625,
that it wasn't setting the session cookie to let the frames know you were logged
in.  If it's still broken for you using a recent nightly build, please reopen
this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

17 years ago
Seems fixed now - works on Windows and Linux 
Status: RESOLVED → CLOSED
You need to log in before you can comment on or make changes to this bug.