Closed Bug 848626 Opened 7 years ago Closed 7 years ago

Versions listed on bug creation are in random order

Categories

(bugzilla.mozilla.org :: General, defect, major)

Production
defect
Not set
major

Tracking

()

RESOLVED FIXED

People

(Reporter: LpSolit, Assigned: glob)

References

Details

(Keywords: regression)

While reporting a new bug in the Bugzilla product, I realized that the version list was in random order. It looks like they are sorted "chronologically", i.e when the versions were added into the DB, making it very hard to find the one you want.
Assignee: nobody → glob
enter_bug is calling Bugzilla::Product::preload, which bypasses new_from_list.

Bugzilla::Version objects have LIST_ORDER set to 'id', and custom sorting is performed in new_from_list, so $product->{versions} was being primed with versions sorted by id.

upstream doesn't call preload from enter_bug, removed.

Committing to: bzr+ssh://bjones%40mozilla.com@bzr.mozilla.org/bmo/4.2/
modified enter_bug.cgi
Committed revision 8639.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.