Firefox forcibly replaces entered URL with invalid URL from history

RESOLVED INVALID

Status

()

RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: arvidjaar, Unassigned)

Tracking

17 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

6 years ago
Created attachment 722036 [details]
URL as entered by me

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:17.0) Gecko/20100101 Firefox/17.0
Build ID: 20130215125822

Steps to reproduce:

Using ESR 17.0.3.

I use SSH port tunneling to connect to various places. Usually I setup the same source port 8888 => target-IP:80.

When I enter URL http://localhost:8888/ firefox forcibly replaces it with one of matching URLs from history. Because this history refers to completely different system, access always fails.

I attach three screenshots - after I typed in URL, after I pressed ENTER to connect and Firefox history.


Actual results:

Firefox changes URL http://localhost:8888/ into http://localhost:8888/phpfiles/BladeServerView.php.


Expected results:

Firefox should open URL exactly as written in URL input field
(Reporter)

Comment 1

6 years ago
Created attachment 722037 [details]
URL rewriten by FF
(Reporter)

Comment 2

6 years ago
Created attachment 722038 [details]
History list for localhost:8888
(Reporter)

Comment 3

6 years ago
OK, so it is not rewriting URL, but rather fetches cached content that does not apply here. After clearing cache page opens correctly.

Any way to tell it - do NOT use cached page, go to URL instead? As FF apparently does not offer any way to remove single cached URL, removing everything seems like rather drastic approach.
shift+reload/ctrl+f5 works usually but that will not work to refresh a stale 301/302 redirect.
The site should send a no-cache header to avoid this caching.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.