can't submit releases with relbranches to ship it

RESOLVED FIXED

Status

Release Engineering
Release Automation
--
critical
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: bhearsum, Assigned: bhearsum)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [shipit])

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

5 years ago
This is probably a regression from bug 837107, where we marked "revision" as disabled when relbranch gets set. The unintended side effect of this seems to be that no data is sent for the revision field - so it fails validation. We need to adjust the validation code to allow for an empty revision when relbranch is set. We should probably say something like "tip of relbranch" on releases.html in that case, too.
(Assignee)

Comment 1

5 years ago
Rail and I just talked about this and decided that because we ignore the revision when a relbranch is present, that we should set revision to None in this case, rather than setting it to an ignored one. We'll have to update tag-release.py (and maybe other scripts) to cope with this.
(Assignee)

Comment 2

5 years ago
Created attachment 723466 [details] [diff] [review]
make revision not required when relbranch is present

This patch hasn't been tested yet, but I wanted to get some feedback on how I'm setting "revision" when relbranch is passed. I originally set it to a string like "tip of FOO", but given that revision is sometimes used in hg operations that seemed like a bad thing. Given that, the only sensible thing I could think to set it to was the relbranch name.

How does this sound to you two?
Attachment #723466 - Flags: feedback?(rail)
Attachment #723466 - Flags: feedback?(nthomas)
Comment on attachment 723466 [details] [diff] [review]
make revision not required when relbranch is present

Yup, using relbranch as revision makes sense, since it'll always be "tip of relbranch" - exactly what we need for releases off relbranch.
Attachment #723466 - Flags: feedback?(rail) → feedback+
Attachment #723466 - Flags: feedback?(nthomas) → feedback+
(Assignee)

Comment 4

5 years ago
Created attachment 723945 [details] [diff] [review]
make revision/relbranch mutually exclusive; update tooltips

New in this patch:
* Tested, and works. Sample bumps are here: https://hg.mozilla.org/users/bhearsum_mozilla.com/buildbot-configs/rev/9fec8e618ece, https://hg.mozilla.org/users/bhearsum_mozilla.com/buildbot-configs/rev/393bf7504b5a
* Make revision and relbranch mutually exclusive -- relbranch is disabled when revision is present and vice versa.

I'm not happy with all the duplication in the form templates, but it's not possible to set placeholder/title/disabled until you render the form. I filed an upstream bug on this (https://bitbucket.org/simplecodes/wtforms/issue/143/should-be-able-to-store-widget-arguments), but that doesn't make anything better right now.
Attachment #723466 - Attachment is obsolete: true
Attachment #723945 - Flags: review?(rail)
Attachment #723945 - Flags: review?(rail) → review+
(Assignee)

Updated

5 years ago
Attachment #723945 - Flags: checked-in+
(Assignee)

Updated

5 years ago
Depends on: 850641
(Assignee)

Comment 5

5 years ago
in production.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.