Closed Bug 849056 Opened 10 years ago Closed 10 years ago

Purchase fails due to incorrect error over expiry date

Categories

(Marketplace Graveyard :: Payments/Refunds, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED
2013-03-28

People

(Reporter: krupa.mozbugs, Assigned: keir)

References

Details

Attachments

(1 file)

Attached image screenshot
steps to reproduce:
1. Start the purchase flow for a paid app on your unagi phone
2. Sign in with Identity
3. Enter PIN
4. Confirm your phone number (T-mobile)
5. Choose to pay using your credit card
6. Enter valid credit card info with expiry info set to 03/15
7. Click Buy

expected behavior:
Purchase using credit card is successful

observed behavior:
Purchase fails with "card expiry must be a valid date in the format MMYY". See screenshot.
Summary: 03/15 is not accepted as valid credit card expiry info → Purchase fails due to incorrect error over expiry date
I verified that the error shows up with different credit card info as well.
Resolved.
resolved on test, not pushed to Prod
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
I can still reproduce this error consistently (3 times) on -dev.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Waiting for upload to test.
Fixed on test
Status: REOPENED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → FIXED
This error doesn't happen anymore.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.