[Bluetooth]show on overtap "Rename" in Button

RESOLVED DUPLICATE of bug 833140

Status

--
major
RESOLVED DUPLICATE of bug 833140
6 years ago
6 years ago

People

(Reporter: leo.bugzilla.gecko, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [TD-23548])

Attachments

(2 attachments)

Comment hidden (empty)
(Reporter)

Comment 1

6 years ago
Step :
Settings> Bluetooth > Rename my devices > Change phone name > Write full name

Show on over tap "Rename" in Button.
(Reporter)

Updated

6 years ago
Severity: critical → major
(Reporter)

Comment 2

6 years ago
Hi, Mozilla Team

Once more Please.

There is no character limit for the rename.
Problem arises if you write long rename
Rename and the button looks superimposed.

thanks.
Evelyn,
Do we have character limitation for the name string?
Component: Gaia::Bluetooth File Transfer → Gaia::Settings
(Reporter)

Comment 4

6 years ago
Hi Evelyn,

Name if you write long and overlap button seems.

Please, Checked.
(Reporter)

Comment 5

6 years ago
Created attachment 735603 [details]
name size is over in layout
(Reporter)

Comment 6

6 years ago
Created attachment 735604 [details]
patch for size define

Dear Mozilla Team,

I have modified this bug.
Please check your model and review this code.

Thanks.

Updated

6 years ago
Whiteboard: [TD-23548]
NeedInfo UX team to consider the available description space for the device name.
Flags: needinfo?(firefoxos-ux-bugzilla)

Updated

6 years ago
Flags: needinfo?(firefoxos-ux-bugzilla)

Comment 8

6 years ago
Reassigning from the general UX identity to Eric, as this seems similar to a character limitation/overflow issue that he and Rob addressed in another bug, and since Rob is out this week. Sorry, Eric - I know you're slammed. Please reassign as needed/appropriate.
Flags: needinfo?(epang)
(In reply to Stephany Wilkes from comment #8)
> Reassigning from the general UX identity to Eric, as this seems similar to a
> character limitation/overflow issue that he and Rob addressed in another
> bug, and since Rob is out this week. Sorry, Eric - I know you're slammed.
> Please reassign as needed/appropriate.

To clarify, are we talking about the text that overlaps the toggle?
If so, I believe we have 2 options:

1. Set the character limit to around 15 - I spoke with Przemek about this and it seems like the best answer.
2. If a character limit is not preferable we can always have the ellipses start before the toggle.

Let me know if I've misunderstood the issue. Thanks!
Flags: needinfo?(epang)

Comment 10

6 years ago
It seems like duplicated with Bug 833140
Plz check it.
(Reporter)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 833140
You need to log in before you can comment on or make changes to this bug.