'Permission denied to access property' when calling method: [nslDOMEventListener::handleEvent]

RESOLVED WORKSFORME

Status

()

Core
DOM: Core & HTML
RESOLVED WORKSFORME
17 years ago
16 years ago

People

(Reporter: Marc Ozon, Assigned: jst)

Tracking

Trunk
PowerPC
Mac System 8.6
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9.1) Gecko/20010607
BuildID:    2001060712

Viewing a page on which there is a div (block) with display:none, and which uses
a script to change the display property via listening for a click event,
generates an error in the JavaScript console, and does not change the display
property of the div as expected.  This behaviour worked perfectly in 0.8-0.9
(and maybe earlier) on all platforms I tried, and still works properly in at
least the Windows version of 0.9.1, but seems broken in 0.9.1 on Mac.

The script, when called to produce the expected behaviour, generates the
following error in the JavaScript console:

Error: [Exception... "'Permission denied to access property' when calling
method: [nsIDOMEventListener::handleEvent]"  nsresult: "0x8057001e
(NS_ERROR_XPC_JS_THREW_STRING)"  location: "<unknown>"  data: no]

I assume the 'permission denied' refers to the display property.  Other
properties, e.g. color, can be manipulated in the same way without any problem.

Reproducible: Always
Steps to Reproduce:
1. View http://www.alistapart.com/stories/domtricks2/ (or similar -- the same
thing happens on pages I have with similar scripts and elements)
2. Click on an 'expanding menu' heading


Actual Results:  The expected menu does not expand (i.e. the div with
display:none does not change its display to block).  The error reported above
appears in the JavaScript console.  On the same page, the same scripts
successfully manipulates the color property without any problem.

Expected Results:  Change the display property via the scripts on the page when
the 'expanding menu' heading was clicked.

Comment 1

17 years ago
On Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9.1+) Gecko/ , the bug is 
fully reproduced but since part of the problem involves a <div> tag, could  
the tag help to the problem or is not even call.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

17 years ago
Mac-only issue it seems, I'm not seeing the problem on Win2k nightly 2001061020.
CC'ing mstoltz for security.

Comment 3

16 years ago
Works for me 10/03/2001 branch. Resolving
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.