Homepage as file on local system doesn't load [need to specify file://]

VERIFIED WORKSFORME

Status

--
minor
VERIFIED WORKSFORME
18 years ago
14 years ago

People

(Reporter: mbabcock-mozilla, Assigned: mscott)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.19 i686; en-US; rv:0.9.1) Gecko/20010607
BuildID:    2001060713

I've always had a file on my local system as my startup page.  It was
specified as "/home/.../homepage.html" but as of this build, I now have to
specify the "file://" before that.  Is this intentional?  Is there a good reason
not to support local files starting with a slash?

Reproducible: Always
Steps to Reproduce:
N/A

Actual Results:  Blank page

Expected Results:  HTML page
-> Networking File
Assignee: asa → dougt
Component: Browser-General → Networking: File
QA Contact: doronr → tever
There is a bug on this already
Whiteboard: DUPEME

Comment 3

18 years ago
we have the same issue in commandline apps for linux i think se would know the 
bug...
Whiteboard: DUPEME
yep, the cmd-line issue is bug 50131.

confirming --you need to have file:// prepended to /[path] in order to display a
local file as the home page.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Homepage as file on local system doesn't load → Homepage as file on local system doesn't load [need to specify file://]
sairuh says so

*** This bug has been marked as a duplicate of 50131 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 6

18 years ago
REOPEN: 
This is a separate entry point, and I think a URL should be required here.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
let scott determine this.
Assignee: dougt → mscott
Status: REOPENED → NEW

Updated

18 years ago
QA Contact: tever → benc

Comment 8

17 years ago
->prefs
Component: Networking: File → Preferences

Comment 9

17 years ago
I promised to make my case for having different input -> URL processing between
the home page pref and launching from the line command.

Here it is:
the home pref should behave like the location box. People generally are going to
expect the two areas to work consistently. There has been some discussion on
what precisely SHOULD work in location (I for one, have argued that local file
paths should work, internet keywords should be off, etc...) but the main point
here is that there is some consistency that is expected between the two entrypoints.

launching from the line command should give primacy to interpreting as a local
file (in local filesystem syntax), and ONLY support a URL if the URL is explicit
("mozilla http://www.google.com", not "mozilla google"). For example, most users
of shell scripts are not going to want to go hunting for a local file path ->
file: URL converter, for one thing it as non-trivial as it sounds in every OS we
build on. 

Comment 10

17 years ago
This also happens under windows ME.

Comment 11

15 years ago
Hello everyone in this bug board.

I'm making an encyclopaedic CDROM about freshwater fishes, and I would like to 
distribute a version of Moz that could have the local CDROM index.html as home 
page to start.

Unfortunately, nothing seams to work properly. I have to deal with the fact 
that the current drive letter may change (CDROM UNIT) on every computer, with 
partitionned disk etc...

I tryed almost every combination of slash file: etc... but cannot find a way 
to do this. Even some complicated delphi bat processing wont do a better work.

That's so sorry because the project will be out soon, and I would like to give 
the user the choice at start menu to choose between moz and their current 
browser (often IE).

Thanx if anyone have a suggestion.
Product: Browser → Seamonkey

Comment 12

14 years ago
Is this still a problem under Linux? It WFM, Mozilla 1.8a6, WinXP.
tested with 20050126-trunk mozilla bits, and when I set my homepage to
/home/sairuh, it now loads the page as file:///home/sairuh --so marking w4m.
Status: NEW → RESOLVED
Last Resolved: 18 years ago14 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 14

14 years ago
On my Fedora Core 3 (Linux) install with Firefox 1.0 this is no longer a problem
either.

WFM as well.
Status: RESOLVED → VERIFIED

Comment 15

14 years ago
re #11: Dadoo, you probably should look at bug 143021.
You need to log in before you can comment on or make changes to this bug.