[Buri][SOS]Sometimes the Emergency call interface display error when the phone is locked

RESOLVED WONTFIX

Status

P2
normal
RESOLVED WONTFIX
6 years ago
6 months ago

People

(Reporter: sync-1, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-)

Details

(Whiteboard: triaged)

Attachments

(2 attachments)

16.82 KB, image/jpeg
Details
1011.57 KB, application/octet-stream
Details
(Reporter)

Description

6 years ago
+++ This bug was initially created as a clone of Bug #408158 +++
 
 Created an attachment (id=348420)
 snapshot
 
 CONTACT INFO (Name,Phone number):
 Li Xin
 Tel:(021)61460666-6884
 
 DEFECT DESCRIPTION:
 Sometimes the Emergency call interface display error when the phone is locked
 
 REPRODUCING PROCEDURES:
 1.Settings->Phone lock->enable passcode lock
 2.press power key to lock screen->wake the screen
 3.click the "Emergency call" button on passcode lock interface
 4.dial a Emergency call(112)->check the Emergency call interface 
 The speaker icon display as Bluetooth icon==>KO1.
 The Emergency call interface becomes ordinary call interface after 5 sec==>KO2.
 
 EXPECTED BEHAVIOUR:
 The Emergency call interface display normally
 
 ASSOCIATE SPECIFICATION:
 TEST PLAN REFERENCE:
 TOOLS AND PLATFORMS USED:
 USER IMPACT:
 REPRODUCING RATE:
 For FT PR, Please list reference mobile's behavior:
 Build ID:
 20130218070201
 ++++++++++ end of initial bug #408158 description ++++++++++
 
 
 
 CONTACT INFO (Name,Phone number):
 
 DEFECT DESCRIPTION:
 
 REPRODUCING PROCEDURES:
 
 EXPECTED BEHAVIOUR:
 
 ASSOCIATE SPECIFICATION:
 
 TEST PLAN REFERENCE:
 
 TOOLS AND PLATFORMS USED:
 
 USER IMPACT:
 
 REPRODUCING RATE:
 
 For FT PR, Please list reference mobile's behavior:

Updated

6 years ago
blocking-b2g: --- → tef?
Flags: needinfo?(anshulj)
Not a blocker in my opinion, the emergency call is progressed and the passcode is not bypassed.
I agree.  It's not great UX by any means but don't feel like a blocker.
blocking-b2g: tef? → -

Updated

6 years ago
Whiteboard: triage
Whiteboard: triage → triaged

Comment 3

6 years ago
Created attachment 729958 [details]
snapshot

Comment 4

6 years ago
I think it is a blocker.when make a emergency call,trigger "telephony-new-call" message and ordinary call screen appears.But ordinary call screen should not appear.
Please resolve this problem as soon as possible.
(Reporter)

Comment 5

6 years ago
In the function openCallScreen(),openWindow() function open call screen.So we can depend on locked/unlocked states to decide open call screen  or not,because emergency call is made in locked states.

Comment 6

6 years ago
In the function openCallScreen(),openWindow() function open call screen.So we
can depend on locked/unlocked states to decide open call screen  or not,because
emergency call is made in locked states.
(In reply to liangxin from comment #4)
> I think it is a blocker.when make a emergency call,trigger
> "telephony-new-call" message and ordinary call screen appears.But ordinary
> call screen should not appear.
> Please resolve this problem as soon as possible.

Still do not understand why this should be a blocker. Can you please provide more details about what is problem here?

Comment 8

6 years ago
Maybe you can add a flag to distinguish Emergency call or dailer app call.According to the flag to decide open ordinary call screen or not. Or Emergency call use 
directly ordinary call screen.
Emergency call appears two call screen which is so strange.

Updated

5 years ago
Flags: needinfo?(anshulj)

Comment 9

5 years ago
Created attachment 734947 [details]
video

Hi,

The attachment is the video of this issue.Why the design is the dialer interface will display after the Emergency call interface several sec later?

Updated

2 years ago
Blocks: 1258652

Comment 10

6 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.