MozillaBuild uses wrong path for MSVC11 Express

RESOLVED DUPLICATE of bug 903945

Status

()

Core
Build Config
RESOLVED DUPLICATE of bug 903945
5 years ago
4 years ago

People

(Reporter: Mitch, Assigned: Mitch)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
start-msvc11-x64.bat output below:

"Mozilla tools directory: C:\mozilla-build\"
Visual C++ 10 Express directory: C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\
Visual C++ 11 directory: C:\Program Files (x86)\Microsoft Visual Studio 11.0\VC\
Visual C++ 11 Express directory: C:\Program Files (x86)\Microsoft Visual Studio 11.0\VC\
Windows SDK directory: C:\Program Files (x86)\Windows Kits\8.0\
Windows SDK version: 8.0
Using VC 2012 built-in SDK
The system cannot find the path specified.
Mozilla build environment: MSVC version 11.
(Assignee)

Comment 1

5 years ago
Created attachment 722735 [details] [diff] [review]
Use x86 cross compiler for x64 target (patch v1)

There doesn't appear to be a native x64 cl.exe with the Express edition, so the only option is to use the 32-bit cross compiler to produce x64 builds.
Attachment #722735 - Flags: review?(gps)

Comment 2

5 years ago
Comment on attachment 722735 [details] [diff] [review]
Use x86 cross compiler for x64 target (patch v1)

I'm not sure what the full implications of this are. Ted should be able to review this.
Attachment #722735 - Flags: review?(gps) → review?(ted)
Comment on attachment 722735 [details] [diff] [review]
Use x86 cross compiler for x64 target (patch v1)

Review of attachment 722735 [details] [diff] [review]:
-----------------------------------------------------------------

This isn't right. You're modifying the path that's supposed to setup VC11 pro, not express. From your log output it looks like we're detecting your Express install as Pro. :-/

Maybe the logic in guess-msvc.bat needs an update instead?
http://hg.mozilla.org/mozilla-build/file/tip/guess-msvc.bat
Attachment #722735 - Flags: review?(ted) → review-
I have VC 2012 Pro installed here now, so if you want to compare notes on what registry keys are present we can do that.
(Assignee)

Comment 5

4 years ago
Bug 903945 has active work on it so I'm resolving this as a duplicate.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 903945
You need to log in before you can comment on or make changes to this bug.