[REGRESSION] Removing workaround about 'hold-home' during FTU it's not working with PIN CODE

RESOLVED FIXED

Status

Firefox OS
Gaia::First Time Experience
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: borjasalguero, Assigned: alive)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Comment hidden (empty)
(Reporter)

Updated

5 years ago
Depends on: 814840
(Reporter)

Comment 1

5 years ago
After bug 814840 we have a regression when PIN Code it's required by SIM Card. This is due to here https://github.com/mozilla-b2g/gaia/commit/449c2c10f388c08cc9b63a84b18c2da312b357b8#L6R42 we are requesting a method FtuLauncher.getFtuOrigin() which it's not working as expected.

In a first sight it's not working due to in that method you have https://github.com/mozilla-b2g/gaia/commit/449c2c10f388c08cc9b63a84b18c2da312b357b8#L3R24 . However, when you return '_ftuURL' this it's not set yet! This is due to you are setting this param inside an 'asyncStorage' https://github.com/mozilla-b2g/gaia/commit/449c2c10f388c08cc9b63a84b18c2da312b357b8#L3R98 , and it takes around 1 second. That's why '_ftuURL' it's not set properly, and instead of having the standalone SIM screen of FTU App, we are showing the common PIN CODE screen one due to condition it's not working as expected.
https://github.com/mozilla-b2g/gaia/commit/449c2c10f388c08cc9b63a84b18c2da312b357b8#L6R42

I dont know if it's better to fix this or backout your commit, make the modification needed and review it again.
Assignee: nobody → alive
I will fix it.
(Reporter)

Comment 3

5 years ago
Thanks! ;)
Created attachment 723317 [details]
https://github.com/mozilla-b2g/gaia/pull/8560

The original logic in SimLock.js works because: Ftu was running upon lockscreen before. And Sim Pin Dialog would skip if LockScreen is locked.
Attachment #723317 - Flags: review?(timdream)
Attachment #723317 - Flags: review?(timdream) → review+
master https://github.com/mozilla-b2g/gaia/commit/42c94d81bc61ea91013bad66286013c4a7ff8ed2
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.