neverwinternights.com - [LAYER]Neverwinter night FAQ un-readable (bad javascript?)

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
P4
normal
RESOLVED FIXED
17 years ago
3 years ago

People

(Reporter: Rick Niles, Assigned: bc)

Tracking

Details

(URL)

(Reporter)

Description

17 years ago
This maybe a legit Javascript bug, but I'm betting it's
a Evangelism bug of invalid Javascript.  However, I really
think these guys would be more likely to fix their broken
Javascript that say http://www.sony.com (grrr..)

Can someone figure out which it is and send a e-mail
the webmaster if it really is broken Javascript?

Comment 1

17 years ago
This is due to non-standards complient code methinks. It detects either NS4 or
IE4 but not apparently anything above. Setting to evangelism

-mike

Comment 2

17 years ago
Layers are no longer supported. See bug 50711 for further details.
Reassigning to Evangelism component.

Here is a sample of the non-W3C-compliant HTML at this site:

<script language="Javascript">

 var bName = navigator.appName;
 var bVer = parseInt(navigator.appVersion);
 var NS4 = (bName == "Netscape" && bVer >= 4);
 var IE4 = (bName == "Microsoft Internet Explorer" && bVer >= 4);
 var NS3 = (bName == "Netscape" && bVer < 4);
 var IE3 = (bName == "Microsoft Internet Explorer" && bVer < 4);
 
// LAYER SWITCHING CODE
if (NS4 || IE4) {
 if (navigator.appName == "Netscape") {
  layerStyleRef="layer.";
  layerRef="document.layers";
  styleSwitch="";
  }else{
  layerStyleRef="layer.style.";
  layerRef="document.all";
  styleSwitch=".style";
 }
}

//Show layers
var onLayer = ""
function showLayer(layerName){
if (NS4 || IE4) {

    hideLayer(onLayer)
 }
 if (NS4 || IE4) {
  eval(layerRef+'["'+layerName+'"]'+styleSwitch+'.visibility="visible"');
 }  else {
  window.location.hash = layerName + "H"
 }
 onLayer = layerName 
}

//Hide Layer
function hideLayer(layerName){
 if (layerName != "") {
   if (NS4 || IE4) {
   eval(layerRef+'["'+layerName+'"]'+styleSwitch+'.visibility="hidden"');
  }
 } 
}

</script>
Assignee: rogerl → bclary
Component: Javascript Engine → Evangelism
QA Contact: pschwartau → zach

Updated

17 years ago
Summary: Neverwinter night FAQ un-readable (bad javascript?) → [LAYER]Neverwinter night FAQ un-readable (bad javascript?)
(Assignee)

Updated

17 years ago
Priority: -- → P4
(Assignee)

Comment 3

17 years ago
Arun, I'm giving you all the Linux bugs. If these bugs can be confirmed for
other OS's please (someone) change the Platform/OS to All/All and reassign to
the default Evangelism Component Owner.
Assignee: bclary → aruner
(Assignee)

Comment 4

17 years ago
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Version: other → unspecified
(Assignee)

Comment 5

17 years ago
Arun, I am taking your Linux bugs minus banks. Hope you don't mind.
Assignee: aruner → bclary
(Assignee)

Updated

17 years ago
Summary: [LAYER]Neverwinter night FAQ un-readable (bad javascript?) → neverwinternights.com - [LAYER]Neverwinter night FAQ un-readable (bad javascript?)
*** Bug 105100 has been marked as a duplicate of this bug. ***

Comment 7

16 years ago
they moved over to Hiermenus, fixed!
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.